10 Replies Latest reply on Mar 21, 2010 11:33 PM by jrc

    DG45ID, v117: SATA Trouble

    BetterToday

      I'm experiencing a strange behaviour on my DG45ID motherboard:

       

      Although I've connected hard drive "A" to SATA port #1 and hard drive "B" to SATA port #2, BIOS, Windows Installer and Windows itself list drive "B" first.

       

      This keeps Windows from installing!   (if both drives hold partitions from a previous installation)

       

      Here's my configuration:

      • Intel DG45ID mainboard
      • Sony BDRW Bluray drive, plugged into SATA port #0
      • Western Digital WD5000AAKS 500GB hard drive, plugged into SATA port #1
      • Western Digital WD10EADS 1TB hard drive, plugged into SATA port #2

      The only current remedy is to unplug the 1TB drive to be able to install Windows onto the 500GB drive. After that it's possible to plug in the 1TB drive again in order to use its data.

       

      But after that, even the BIOS now doesn't read correctly that the 500GB drive is plugged into a port with a lower ID. Although listed first in the Drive Configuration page, when selecting Boot Menu Type "Normal", having Hard Drive Order set to list the 500GB drive first (which ISN'T the case by default!), the system still fails to boot because it launches from the 1TB drive!

       

      Now after installing Windows 7 and plugging in the 1TB drive again, the only remedy is to set the BIOS Boot Menu Type to "Advanced" (the German translation of the BIOS calls that setting erroneously "Forward") and to set the Boot Drive Order manually.

       

      Something is really wrong with this BIOS!

       

      This should get fixed soon.

       

      Thanks,

      Axel Dahmen

        • 1. Re: DG45ID, v117: SATA Trouble
          mechbob

          Have you tried pressing f10 at POST and changing the Boot order??

          • 2. Re: DG45ID, v117: SATA Trouble
            BetterToday

            Yes, and this is the really weird point:

             

            When I've been setting up "Normal" boot mode, then pressing <F10> works the opposite way it should: Selecting the 500GB drive will boot the 1TB drive while selecting the 1TB drive boots the 500GB drive...

            • 3. Re: DG45ID, v117: SATA Trouble
              mechbob

              Try switching the SATA plugs on the MOMBO and see what happens , How many other SATS devices do you have pluged up ?

              • 4. Re: DG45ID, v117: SATA Trouble
                Cpt.Dogfruit

                Hi

                I can confirm that not all 45ids with this BIOS do taht...

                Have you tried going back a BIOS?

                And have you more than one OS installed?

                It might be worth you unplugging everyhting, clearing the CMOS properly, the in the BIOS F9, then F10, (set defaults, save) then try to install a fresh install of Win 7

                • 5. Re: DG45ID, v117: SATA Trouble
                  BetterToday

                  Thanks, guys, for trying to help! It's very much appreciated!

                   

                  mechbob wrote:

                   

                  Try switching the SATA plugs on the MOMBO and see what happens , How many other SATS devices do you have pluged up ?

                  I'll do that right tomorrow. Currently I'm working with this machine.

                   

                  Please refer to my first posting about my SATA configuration. It's all mentioned there.

                   

                  Cpt.Dogfruit wrote:

                   

                  Have you tried going back a BIOS?

                  And have you more than one OS installed?

                  It might be worth you unplugging everyhting, clearing the CMOS properly, the in the BIOS F9, then F10, (set defaults, save) then try to install a fresh install of Win 7

                  • This error might be reproducible with particular hard drives installed only. So it's quite plausible that you can't reproduce the problem with your configuration. Maybe some SATA enumeration routines within the BIOS have a sorting bug, perhaps not sorting by port number but by drive name instead.
                    .
                  • I haven't switched to another BIOS version. And I guess I won't. From my perspective it's up to Intel to find a remedy for that problem. I have a workaround to work with. They should seek that the next version is working properly.
                    .
                  • Windows 7 is (and has been) the only OS running on that machine yet. No multi-boot.
                    .
                  • I'll try your suggestions right tomorrow. Today I need my machine, I'm afraid. With clearing the CMOS you mean "Load save configuration", right?

                   

                  Thanks again for your efforts!

                  • 6. Re: DG45ID, v117: SATA Trouble
                    Cpt.Dogfruit

                    Hi,

                    when i say clear CMOs i mean unplug the system completly and take out the CMOS battery for at least 15 mins.

                    "From my perspective it's up to Intel to find a remedy for that problem. I have a workaround to work with. They should seek that the next version is working properly." The problem with this is that you seem to be the only one with the issue at the moment, so they won't coz tehy dont think tehr eis an issue. Also have you contacted intel support? I dont believe they actually read all the threads here....
                    ."

                    • 7. Re: DG45ID, v117: SATA Trouble
                      BetterToday

                      Cpt.Dogfruit wrote:

                       

                      Hi,

                      when i say clear CMOs i mean unplug the system completly and take out the CMOS battery for at least 15 mins.

                       

                      The problem with this is that you seem to be the only one with the issue at the moment, so they won't coz tehy dont think tehr eis an issue. Also have you contacted intel support? I dont believe they actually read all the threads here....
                      ."

                      Ah, I see...

                       

                      I've actually contacted Intel Support and they have escalated the issue now.

                       

                      The reason why I'm the only one to have noticed this problem yet may be because of my SATA configuration and because not too many people have actually re-installed their Windows 7 installation yet. These preconditions all have to meet in order to reproduce the problem. It didn't arise at my machine at first installation, too. At that time my D: drive didn't have any valid partition. But now it has. And, hence, now the problem becomes visible.

                      • 8. Re: DG45ID, v117: SATA Trouble

                        Hi,

                        I see that you didn't have a problem in the initial  installation. I've installed and re-installed Windows 7 on different machines and when I encounter problems on re-installation on the same machine, I use a hard drive eraser to wipe the disk. This erases all information on the disk and it will be like a new disk. When installing Windows 7, it has to be initialized again i.e. create partition/s and do format. You can get a free hard drive eraser on the internet (just google it) and burn it on a disc.

                        • 9. Re: DG45ID, v117: SATA Trouble
                          BetterToday

                          Thanks for trying to help.

                           

                          I've already done that.

                           

                          The second disk must keep its data. And, by the way, erasing/wiping the MBR is not supposed to be standard procedure when re-installing Windows 7.

                           

                          I'm pretty sure that I've done all I can do to exclude an error from my side. Particularly when the BIOS boots from the wrong disk, it becomes evident that the error is in the BIOS and not anywhere else.

                          • 10. Re: DG45ID, v117: SATA Trouble
                            jrc

                            Hello!

                             

                            I noticed that the docs and MB "sticker" have the SATA ports numbered wrong. Look at the white lettering directly on the MB to see which SATA  port is 0-4.