6 Replies Latest reply on Oct 11, 2015 5:39 PM by wb_Intel

    Windows 7 Professional x64 integrated Intel 82577LM network controller on Latitude e6510 - EEPROM failure because of Intel Link Speed hardware diagnostics

    thermo_bit

      So, basically I've got same problem as the guy who posted topic Integrated Intel 82577 network controller - EEPROM failure.

      But in my case this problem appeared slighlty different. While browsing Internet, connection was breaked, because of temporary connections problem with LAN (router had to be reset).

      But first I thought it's the fault of NIC, so I decided to make NIC hardware diagnosicts using Intel Link Speed driver options.

      Test failed and I've got info that EEPROM diagnostics failed.

      Then NIC stopped working.

      I've tried deleting and installing again the driver (both using drivers from dell support website and intel download center), also tried installing driver for 82577LC, reinstalling chipset drivers, deleting entries in windows registry.

      Nothing worked.

      Even booted Ubuntu liveUSB - linux also don't recognized this NIC.

       

      Is it totally physically bricked or just firmware is really messed up?

      How could I diagnose this by myself? Both on Windows and unix?

      Has Intel got some hardware diagnostics tool, which could detect such problems?