2 Replies Latest reply on Sep 29, 2015 5:50 AM by prashast.srivastava

    Not able to ping galileo gen 2 board

    prashast.srivastava

      Hi, so I was trying to set up my ssh connection to my galileo gen2 board by connecting an ethernet cable directly from my board to my laptop but I am not able to. In order to see if my connection was setup or not, I was trying to ping the board from my laptop which I am not able to do and the error comes as "destination host unreachable". The sketch that I am using to set up is:


      void setup()

      {

        // put your setup code here, to run once:

        system("telnetd -l /bin/sh"); //Start the telnet server on Galileo

        system("ifconfig eth0 192.168.1.69 netmask 255.255.0.0 up");

       

      }

      void loop(){}


      Now in this thread Using Galileo Linux over Ethernet(Telnet) it was stated to put the static ip for board as 169.254.x.x. I tried doing that(eg 169.254.1.1) but wasn't able to setup my connection. After that I tried assigning the static ip to my board in the range which my router is assigning to my laptop(laptop's ip: 192.168.1.15), so I assigned it 192.168.1.69 but still it didn't work and I couldn't ping my board. My laptop is connected to internet through wifi and the I've checked that the ip assigned to my laptop is always (192.168.1.15), even when I reboot(is there any other way to check if my router is assigning me a static ip? Would that matter?) I've booted from SD card image provided on intel and it's working fine because blink sketch persists even after I reboot the board, so that shouldn't be an issue.

       

      Kindly let me know if there's any fundamental mistake that I am making while trying to set up the connection.