6 Replies Latest reply on Nov 8, 2015 1:27 AM by Cesar Badilla

    Reproducible Machine Check Error with 5700HQ

    blackthund3r

      Hi there,

       

      I just received a CyberPowerPC Fangbook HX6-100 (a rebranded whitebook MSI GE62 Apache) with an Intel 5700HQ processor.

       

      I first saw a bluescreen (Machine Check Error) when trying to use Click-To-Run Office 2016. After getting it installed locally these errors stopped.


      I then attempted to use VMware Workstation to load an Ubuntu VM and as soon as the installation got going (files were being installed, not just copied, so the CPU usage picked up) I got another Machine Check Error:

      Event log shows this: The computer has rebooted from a bugcheck.  The bugcheck was: 0x0000009c (0x0000000000000000, 0xffffd00020654860, 0x0000000000000000, 0x0000000000000000).

       

      My event log also has many entries in the format:

      The speed of processor X in group 0 is being limited by system firmware. The processor has been in this reduced performance state for 71 seconds since the last report.

      (There are always 8 entries at a time where X is between 0 and 7; I assume each is one of the 8 logical CPUs in a 4 core / 8 thread system)

       

      After several reboots, it seems I am entirely unable to use virtualisation without blue screens on this machine, despite VT-x being enabled in the BIOS. Even though the VT-x technology is working fine, the VM does not work for long enough for this to be useful. I have received about eight or nine of these blue screens today on a laptop that is less than one day old. Running Prime95 and/or FurMark do not cause the issues, so I'm assuming this is a glitch affecting certain CPU instructions.

       

      I raised a ticket at MSI and received no reply. CyberPower told me to just torture test it.

       

      A few web searches reveals I am far from alone in this issue:

      MSI GE62 - 2QL BSODs (Machine Check Exception)

      https://bugzilla.kernel.org/show_bug.cgi?id=103351

      http://steamcommunity.com/app/570/discussions/0/537405286656286392/

       

      I will be using this laptop for my Computer Science degree, so I will need the power of this chip to support both Linux VMs and a lot of code compilation. If I do not get this sorted I will be left with no choice but to return the machine as unusable and purchase a laptop with a previous generation CPU (something like a 4720HQ).

       

      Is there a fix for this? Disabling SpeedStep makes the VM run for a bit longer, but this is an unacceptable solution as I will not get Turbo Boost when plugged in, and the battery life will be extremely poor. I will never be able to take notes in lectures!

       

      I have tried all the latest Intel drivers, including the latest chipset driver release. I have tried both the latest Nvidia GTX 960M driver, and the one that came on the driver DVD. This is Windows 10 x64 with 16GB of RAM. There is no overclock and I am using the stock BIOS (version 10E, CyberPower release).

       

      Many thanks

       

      Added another link and more event log details - Chris Hammond

        • 1. Re: Reproducible Machine Check Error with 5700HQ
          Wes991182

          I too have this same problem. I have been using a non-overclocked i5-5675c for several weeks with no issues. However, I found that any time I try to launch Office 2016 apps, I get the BSOD with MACHINE_CHECK_EXCEPTION.

           

          Event viewer:

          - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

          - <System>

           

          <Provider Name="Microsoft-Windows-WER-SystemErrorReporting" Guid="{ABCE23E7-DE45-4366-8631-84FA6C525952}" EventSourceName="BugCheck" />

          <EventID Qualifiers="16384">1001</EventID>

          <Version>0</Version>

          <Level>2</Level>

          <Task>0</Task>

          <Opcode>0</Opcode>

          <Keywords>0x80000000000000</Keywords>

          <TimeCreated SystemTime="2015-09-24T19:10:49.000000000Z" />

          <EventRecordID>3185</EventRecordID>

          <Correlation />

          <Execution ProcessID="0" ThreadID="0" />

          <Channel>System</Channel>

          <Computer>DESKTOP-TU4LVK4</Computer>

          <Security />

          </System>

          - <EventData>
          <Data Name="param1">0x0000009c (0x0000000000000000, 0xffffd000e8bf0760, 0x0000000000000000, 0x0000000000000000)</Data>
          <Data Name="param2">C:\Windows\MEMORY.DMP</Data>
          <Data Name="param3">092415-3078-01</Data>

          </EventData>

          </Event>

             Another link with others who are experiencing the same problem: http://answers.microsoft.com/en-us/office/forum/office_2016-officeapps/random-bsod-with-office-2016-official-release/a6a6aa1a-c055-4eba-bfb7-eceb59dca264

             Everyone experiencing this problem, whether with a game, virtual box, or 2016, is using a Broadwell processor.

             Thanks for your time and consideration.



          • 2. Re: Reproducible Machine Check Error with 5700HQ
            SweSharkie

            Yeah same here. I have an Clevo P651SE-A bought from XMG as an P505.

             

            The exact same thing happens to me. I've run all the stresstests and benchmarks and no errors. But if I try to start up Ubuntu in VirtualBox or Office 2016 then you get an BSOD.

             

            I've talked to Intel via their chat and they feel it's not their fault and after some digging they may have a point.

             

            The file causing the BSOD's are HAL.dll. Hardware Abstraction Layer. And after running BITS I found that the BIOS fails on several points. I do believe that this is an error how the CPU power-states are handled in the firmware and this might be fixable in an BIOS update.


            I feel this is also confirmed by the fact that disabling Speedstep greatly alleviates the problem.

             

            This appears to be a OEM problem, that being said, it does give Intel a rather bad name since everybody affected runs a certain CPU so Intel really should at least spend some resources on helping the OEM's solve the problem.

             

            That's my 2 cents.... 

            • 3. Re: Reproducible Machine Check Error with 5700HQ
              blackthund3r

              I'm glad in a way that this is actually a cross-brand issue because it means Intel will have a massive sample of machines to work with.

               

              As an update on my situation, I have arranged for my laptop to be exchanged for a model with a 4720HQ (Fangbook Edge). As I need this machine for university (where Office and Linux are crucial to my Computer Science course) I cannot really wait around for a fix.

               

              As I understand from my limited OS knowledge, a bit of deeper digging will be required as the Hardware Abstraction Layer is essentially a common interface through which device drivers can communicate with the hardware. For this is trigger a blue screen it would probably indicate a (very) rogue driver that's somehow corrupting the kernel, or a hardware fault that's causing a kernel fault. As this is a cross-platform issue and Windows is unable to handle the fault I'm going to take a guess that it's something meta-software, and your investigations into the BIOS / system firmware are a much better route of enquiry.

               

              I would suggest that since the BIOS must contain code provided by Intel (so that all systems know how to initialise and use each CPU model), Intel will be able to produce a blanket fix that will be rolled out via OEMs in BIOS or EC updates. At worst, this could be a recall job (remember the Sandy Bridge SATA saga?) but I'm guessing it's probably something Intel are working on now. If you look in their latest Broadwell specification (http://www.intel.com/content/dam/www/public/us/en/documents/specification-updates/5th-gen-core-family-spec-update.pdf) there are many errata, some of which are noted as unfixed. Chances are, fixes will come through the vendors to consumers over the next couple of months. My advice is that unless you need a Broadwell-only CPU instruction, you're best off returning your laptop and purchasing a 4720HQ model. The real world performance difference is minimal and worst. See Intel Core i7 4720HQ vs 5700HQ fora comparison.

              • 4. Re: Reproducible Machine Check Error with 5700HQ
                Cesar Badilla

                Hello blackthund3r

                 

                Please  attach your event log here and the msinfo32 file and the dxdiag. In order to open DirectX Diagnostic Tool click on the Start button , type dxdiag in the Search box, and then press ENTER.

                 

                You may get more information about this issue here: Random BSOD with Office 2016 official release. - Microsoft Community*

                 

                Regards,

                Caesar B.

                 

                *Other names and brands may be claimed as the property of others.

                • 5. Re: Reproducible Machine Check Error with 5700HQ
                  BenniBee

                  Hello!

                   

                  I have the same problem you describe with the newest Office applications and also with DOTA 2 and CS:GO!

                  I posted here also but did not receive an answer yet.

                   

                  MSI and Clevo rolled out updates to their BIOS which fixed their problem already and I hope Intel can work together with the other notebook manufacturers to fix

                  this problem as soon as possible. It is really annoying to have to be honest. Especially on really new and rather expensive hardware.

                  Did you find a fix for your laptop?

                   

                  Kind regards,

                  Benjamin

                  • 6. Re: Reproducible Machine Check Error with 5700HQ
                    Cesar Badilla

                    Hello BenniBee,

                     

                    Please  attach your event log here and the msinfo32 file and the dxdiag.

                     

                    In order to open DirectX Diagnostic Tool click on the Start button , type dxdiag in the Search box, and then press ENTER.


                    Also the Graphics Drivers — Intel® Graphics Driver Report  this information is crucial for us to get to the root of the issue and find a resolution as soon as possible.


                    Regards,


                    Caesar B.