1 2 3 Previous Next 40 Replies Latest reply on Nov 16, 2015 8:54 PM by Cesar Badilla

    Need Help! Intel NUC not booting...

    yali

      Hello all,

       

      I recently purchased an Intel NUC D54250WYK about a week ago but so far have not been able to get it to boot up.

       

      Currently the NUC's power button is flashing blue x3 for 1 second then about a 4 second pause which then repeats and turns off and restarts after cycling a few times.

       

      I am using crucial ram from intel's approved list and have also confirmed it to be working on another machine. I've tried swapping the ram around, using one at a time, using different ram from working machines but so far no luck.

       

      The NUC seemed to initially work when i first tried it in that the power light was solid blue but would not display anything on my TV which i think was due to the bios being out of date. The blinking light appeared after i attempted to update the bios with a usb stick.

       

      If anyone can offer advice/solutions i would be grateful.

       

      yali

        1 2 3 Previous Next