8 Replies Latest reply on Oct 12, 2015 6:43 PM by Will_S

    Edison arduino not working with serial displays

    Will_S

      Hi all,

       

        I have a 4D systems 4.3 inch touch display that works fine with an arduino uno, but will not work on the Edison arduino breakout board. It should work by changing Serial.Begin --> Serial1.begin. But it doesn't. I searched and found a few threads about executing a zillion commands and editing some files, but I figure the firmware would have been updated by now. I tried the suggestions anyway, but got errors.

       

      The display is wired to the Edison as such:

       

      Display
      Edison Arduino
      5v5v
      GNDGND
      TXPin 0 arduino header (rx)
      RXPin 1 arduino header (tx)

       

      I'm wondering if it is an issue with the 4dsys library files (attached) not playing nice with the linux o/s... Anyone have any idea?

       

      Let me know if anyone needs any more info.

       

       

       

      02.jpg

       

      1.7.2 Yocto

      1.6.5 Arduino

       

      I should note that I tried genie.Begin(Serial1). That doesn't work either.