3 Replies Latest reply on Sep 29, 2015 1:51 PM by Intel_Alvarado

    USB errors

    ppafin

      I have Intel Edison with the breakout board and I am facing some USB instabilities with this setup.

       

      Here is setup in details:

       

      • configure_edison --version => 159
      • External +12 V supply for J21
      • OTG Adapter for USB port (J16)
      • USB Headset, Logitech H340 (Bus 001 Device 002: ID 046d:0a38 Logitech, Inc.)
      • WiFi active

       

      Problems:

       

      1. On boot, I occasionally get "unable to initialize libusb: -99" when doing lsusb.

       

      Rebooting & disconnecting USB fixes this and returns USB to working state:

       

      # lsusb

      Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

      Bus 001 Device 002: ID 046d:0a38 Logitech, Inc.

      Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

       

      2. After using our own audio application with H340 headset, if works once and ends after these messages in dmesg:

       

      [40026.575743] 2:1:1: usb_set_interface failed (-22)

      [41680.432172] dwc3-host dwc3-host.2: xHCI xhci_drop_endpoint called with disabled ep f56719c0

      [41680.432206] dwc3-host dwc3-host.2: xHCI xhci_drop_endpoint called with disabled ep f56719ec

      [41680.432228] dwc3-host dwc3-host.2: Trying to add endpoint 0x1 without dropping it.

      [41680.432256] usb 1-1: Not enough bandwidth for altsetting 1

       

      => Only way to recover this is reboot.

       

      Any ideas?

        • 1. Re: USB errors
          Intel_Alvarado

          Hi,

           

          What USB device are you connecting? Look at the last error from the dmesg output: usb 1-1: Not enough bandwidth for altsetting 1.

          Are you streaming any contents through USB? If you are using a camera, for example, and you get a bandwidth error then you might need to change your streaming or transferring data settings, such as resolution or frame rate.

           

          Sergio

          • 2. Re: USB errors
            ppafin

            Yes, I am using USB audio to audio streaming in/out.

             

            First this "unable to initialize libusb: -99" error, I hardly see any reason for that coming from any bandwidth related issues?

             

            Audio with aplay works fine, and I can repeat playing and recording out over USB audio multiple time (with CD quality), no errors. So bandwidth is probably not the cause. We have sub processes(s) in program for recording and playing audio and after completion we send SIGKILL signal to those and I wonder, will this break something. In PC and other ARM boards with various kernels this has been worked out very reliable over years.

             

            So far only thing which crosses my mind relates to 'old' kernel in Edison (3.10) and some xhci drive code issues on USB3. Even I am using USB2 headset to audio. Any way to obtain newer kernel to Edison?

            • 3. Re: USB errors
              Intel_Alvarado

              Hi,

               

              Just to make sure you have the switch SW1 towards the USB port right, not the micro USB ports?

              Have you already seen this thread Re: Support for Webcams in Edison

              We are working on a new kernel for the Edison, however there’s still no information on when it will be released.

               

              Sergio