3 Replies Latest reply on Sep 30, 2015 4:26 PM by PabloM_Intel

    Edison Failing to Boot

    EasyAs314159

      I've run into a situation where after updating the firmware on the Edison (from a version prior to mid March 2015) it fails to boot on the board I've been developing. However, it continues to boot on the Arduino development board. The older version of firmware booted perfectly and had no issues. Is anyone aware of a firmware change that would cause this behaviour? Is this a configuration issue I can fix?

       

      I have double checked my schematic and there are two possible trouble spots that I think might be the issue:

      • I am not disconnecting the DCIN pin from VSYS when I run the design from battery power. However it still fails to boot even when being powered by an external supply.
      • I have left the PWRBTN# pin floating. I tried disabling the pwr-button-handler.service but that didn't resolve the issue.


      The only other pins connected on the Edison are the SPI bus which runs to the +1.8V side of a TXB0104 level translator.