1 2 Previous Next 24 Replies Latest reply on Oct 26, 2012 10:27 PM by me678

    X25-M + ICH9R + AHCI = No Post


      I have an Asus x38 Maximus Formula mboard, flashed to the latest bios (1403).  With the X25-M plugged in, if I set it to AHCI in the BIOS, it hangs while detecting the SATA port.  If I set it to RAID, it doesn't even POST.  If I unplug it and then POST and set it to IDE, plug it back in, then works just fine (Win7 x64).


      I'd love to have it in AHCI mode so I can hot-plug my external SATA drive for backups.


      Is this a drive/firmware issue or a mboard BIOS (ie Intel controller ROM)?


      Are other people seeing this?


      Connected to the SATA ports:


      1 X25-M 80GB

      1 150GB Raptor

      1 WD 1TB Green

      1 DVD burner

      1 internal SATA drive cage for backups (normally unplugged)

      1 eSATA for external usage (OCZ Throttle, etc)


      So, I have a cable plugged into every slot, although only 4 are powered up at all times.

        • 2. Re: X25-M + ICH9R + AHCI = No Post

          It's kind of hard to load drivers in an operating system, IF THE COMPUTER CAN'T POST in the first place!

          • 3. Re: X25-M + ICH9R + AHCI = No Post

            I've been having the exact same problem, except I've got an ICH10R on my motherboard (Gigabyte GA-EX58-UD4P).  Do you have a G1 or G2 80GB drive?


            I see the same behavior as you (hang during AHCI BIOS drive detection), and it ONLY happens when a Win7 RTM partition is installed on the drive.  If the drive is blank, it is detected no problem.  I previously was running Windows 7 RC1 on this exact drive for months with no issues.  It's only when I got my retail Win7 Pro upgrade that I began seeing this problem.


            Again, as Wachamakalit said, this all happens during the BIOS startup process, well before the OS loads, so it can't be a driver issue.  But there must be some kind of software aspect to the problem, because it only happens when there's a Win7 partition present, as if the AHCI BIOS is reading some information from the partition table or MBR or something and getting confused     .

            • 4. Re: X25-M + ICH9R + AHCI = No Post

              It's a G2, with the latest firmware (not the pulled one, but the latest shipping one).  Come to think of it, I did format it with Win7 Beta 64-bit before I tried to install the Win7 upgrade.


              I took the drive to a friend's house today (hardware review guy for a tech website, with the latest hardware) and it was hot-plugged by win7 + AHCI and detected without any problems. He could see it, write to it, etc.


              But, with it plugged in, it wouldn't get past the drive detection on his mboard POST either. So, it's definately drive related, and not so much the motherboard/system/OS.


              Someone from Intel reported that they will have a fixed BIOS out by the end of the month.  I'll try that, and if it doesn't fix it, I've got an RMA number (good for 9 more days) that I will send it back to ZipZoomFly and get a replacement (and hope a data dump of the OS on the new drive will get past this).

              • 5. Re: X25-M + ICH9R + AHCI = No Post

                After reading your post again, I'm curious about the "If the drive is blank, it is detected no problem."  So, if I wipe the drive (yes, secure full erase, not just a simple reformat), do you think that might fix it?

                • 6. Re: X25-M + ICH9R + AHCI = No Post



                  He even states that the bricked drive (option #4) can be fixed by a secure wipe. Interesting...

                  • 7. Re: X25-M + ICH9R + AHCI = No Post

                    My drive is an 80GB G1 (I have a G2 on backorder but if it has the same issues I may cancel it).


                    In my case, by "blank" I just mean removing all partitions the usual way via FDISK or any other partition software.  I haven't run HDDErase on this drive but it's an interesting idea.  Since I have a working, activated Win7 installation on it right now though, I'm reluctant to mess with it, especially since there aren't a lot of good disk clone tools out there that work correctly with SSDs (i.e. that reproduce the sector offsets correctly).


                    The workaround I'm using is to plug my G1 into a Silicon Image Sil3132 PCIe controller, with my two mechanical drives remaining on the ICH10R.  Seems pretty fast, but I doubt it would support TRIM even if my drive were capable of it.

                    • 8. Re: X25-M + ICH9R + AHCI = No Post

                      Well, the saga continues.  I was able to plug it into several other high-end computers, and other were having problems POSTing with it too. They could plug it in hot in Win7 and see it right off, but not via booting.  Same problems.


                      So, I RMAd it back to zipzoomfly.  Today, they called me up and said that I returned them a bulk drive (based on the serial number) instead of a retail drive.  They claim the serial number doesn't match the drive. (This has been the only SSD drive I have ever seen with my own eyes, so there's no way I could have swapped it with another one.)


                      I got a G2R5, which has the 2mm spacer + full retail box. As far as I could find on Intel's data sheet for these, they don't sell an OEM model with the 2mm spacer.  So, my drive has to be a full retail model.


                      So, now, the question is, did their RMA department screw up and they are just trying to cover it up? I don't know, but I really didn't like their attitude on the phone.


                      They said they had to ship it to Intel for some reason now, and that will take at least 2 weeks.


                      What a disappointment!


                      Needless to say, I'm not sure if I will ever buy from zipzoomfly ever again!

                      • 9. Re: X25-M + ICH9R + AHCI = No Post

                        You didn't even bother to read the previous persons link.


                        Apparently if you install Win7 without setting AHCI in BIOS first, Win7 will not install the driver as it is not needed.


                        So I think if you did a fresh install with AHCI selected in BIOS first you would have fixed the issue.


                        But don't hold me to that, that is only what I understood from my brief skim through previous persons link.

                        • 10. Re: X25-M + ICH9R + AHCI = No Post

                          Well, Zipzoomfly got a new drive back to me, and this one (with no other changes than simply swapping the drive) is working perfectly. It's detected instantly in AHCI mode and is booting perfectly.


                          So, if you can't run your drive in AHCI mode without the BIOS HD detect hanging, RMA the drive and get another one. Defective drive.

                          • 11. Re: X25-M + ICH9R + AHCI = No Post

                            I had this exact same issue, but on an Asus Blitz Formula motherboard.   It would not get past SATA detect during POST with either AHCI nor RAID mode, but would work in IDE mode.   I had Intel RMA me a new drive and everything works again.   Detected instantly in both modes and POST successfully.


                            If anybody else has this same issue, you have a defective drive and you need to RMA it.

                            • 12. Re: X25-M + ICH9R + AHCI = No Post

                              I had the same problem described in this tread; after installing Win7 with ACHI enable my bios won’t recognize the drive. It is Intel aware of this problem? Is the only solution to RMA the drive?


                              • 13. Re: X25-M + ICH9R + AHCI = No Post

                                I too had the same problem. My first drive was shipped with firmware 02G9. I installed Win7 and everything was fine except the fact there wasn't any TRIM so far. After Intel released 02HA I tried to update to the new firmware pretty soon.


                                Note, Win7 was already installed and that was probably causing my new problems: After updating to 02HA the drive wasn't recognized anymore. I just couldn't boot with AHCI enabled anymore. I heard Intel was about to release a new firmware (02HD) so I just switched to my old HDD and hoped for a new firmware fixing everything.


                                Well. It took them almost a month to release 02HD but finally it was there. I tried to update to 02HD but had no success. The SSD seemed to be broken completely. So I did the last thing I could: RMA my drive.


                                14 days later I got a new SSD from Intel. The old one couldn't be fixed so they told me. Afraid of doing another firmware update - the new one was on 02HA only - I took my drive to a friend and we updated it to 02HD in his computer - just to make sure I don't have to RMA another drive.


                                Well, the update went fine (but the drive was still empty, so maybe this is why everything went smooth?!). I copied back my Win7 image and booted up. No problems so far. And I really hope it's going to stay like that...


                                Total amount of time wasted just because I tried to update my SSD: About 7 weeks.


                                • 14. Re: X25-M + ICH9R + AHCI = No Post

                                  This is insane!! So is no way to fix the SSD, but to send it back for RMA?

                                  c'on Intel


                                  1 2 Previous Next