1 2 Previous Next 20 Replies Latest reply on Oct 26, 2015 7:04 PM by MTres19

    WiFi Link 1000 BGN won't connect

    MTres19

      My sister owns an HP Pavilion DV6 VX070AV laptop with a WiFi Link 1000 BGN/Centrino Wireless-N 1000 card for WiFi. Unfortunately, ever since I attempted to update the driver for her, the computer will not connect to WiFi.

       

      The computer also has a Realtek card for Ethernet, which works perfectly, and the computer also works fine with a Netgear WNA1100 USB network adapter. Interestingly, while using the driver from HP names the card "WiFi Link 1000 BGN", Intel's driver names it as "Centrino Wireless-N 1000."

       

      Here is what I have tried:

       

      - I have tried installing both version 16.7.0 and 16.11.0 of the driver from Intel.

      - I have tried updating the driver through HP Support Assistant.

      - I have tried deleting the driver completely (including driver files) and allowing Windows to reinstall the driver.

      - I have tried deleting the driver completely and installing the drivers with Intel's installer.

      - I have tried using a Linux liveDVD. I have tried both Linux Mint 17.1 and KDE Neon 5 (Currently Ubuntu 15.10 beta with latest KDE). Neither of these are able to connect, although KDE Neon displayed the network as WPA, while I know that the network is WPA2.

       

      The router is a Motorola Netopia from around 2008 with WPA2 and 802.11g WiFi.

       

      Does the WiFi Link 1000 BGN have firmware flashed to it that is updated with driver updates? Is this somehow a problem?

       

      I do not think it is a problem with the router, as we have had no issues with other devices connecting.

       

      Any help is much appreciated.

       

      -Matthew

        1 2 Previous Next