1 Reply Latest reply on Sep 21, 2015 8:43 AM by kevin_intel

    I2C recovery Ignore

    Parveensunaria

      Hi all,

       

      I am working on development of a customized android tablet based on intel Baytrail-T.

       

      In the above project we are facing a issue due to I2C.

      Here is the step by step scenario of the issue:

      1-Power on the board and let it boot to the android GUI.

      2-Press the power button for some time and then power off the board from the Android Gui.

      3-Now power on the board without disconnecting the power supply.

       

      Then the board gets stuck and we get the beow logs continously.

       

      [   14.198812] i2c_designware 80860F41:01: ===== REGISTER DUMP (i2c) =====

      [   14.206396] i2c_designware 80860F41:01: DW_IC_CON:               0x65

      [   14.213639] i2c_designware 80860F41:01: DW_IC_TAR:               0x18

      [   14.220957] i2c_designware 80860F41:01: DW_IC_SS_SCL_HCNT:       0x214

      [   14.228295] i2c_designware 80860F41:01: DW_IC_SS_SCL_LCNT:       0x272

      [   14.235592] i2c_designware 80860F41:01: DW_IC_FS_SCL_HCNT:       0x50

      [   14.242811] i2c_designware 80860F41:01: DW_IC_FS_SCL_LCNT:       0xad

      [   14.250032] i2c_designware 80860F41:01: DW_IC_INTR_STAT:         0x0

      [   14.257236] i2c_designware 80860F41:01: DW_IC_INTR_MASK:         0x246

      [   14.264539] i2c_designware 80860F41:01: DW_IC_RAW_INTR_STAT:     0x10

      [   14.271762] i2c_designware 80860F41:01: DW_IC_RX_TL:             0x20

      [   14.279527] i2c_designware 80860F41:01: DW_IC_TX_TL:             0x20

      [   14.286814] i2c_designware 80860F41:01: DW_IC_ENABLE:            0x1

      [   14.293916] i2c_designware 80860F41:01: DW_IC_STATUS:            0x2

      [   14.301360] i2c_designware 80860F41:01: DW_IC_TXFLR:             0x2

      [   14.308489] i2c_designware 80860F41:01: DW_IC_RXFLR:             0x0

      [   14.315595] i2c_designware 80860F41:01: DW_IC_TX_ABRT_SOURCE:    0x0

      [   14.322718] i2c_designware 80860F41:01: DW_IC_DATA_CMD:          0x0

      [   14.330427] i2c_designware 80860F41:01: ===============================

      [   14.339419] i2c-2: recovery ignore

       

      In the above condition either or both the SCL and SDA line remain low on boot time.

      On this I2C we have only one device i.e Audio Codec from TI.

       

      Please help us asap.

      We are on very tight schedule.

       

      Also if i reboot by removing the power supply then the board boots fine.