2 Replies Latest reply on Sep 17, 2015 1:49 PM by rayjcar

    Windows 10 RST driver update stalls

    rayjcar

        I downloaded and tried to run the driver update SetupRST.exe for version 14.6.0.1029.  The file downloads okay, but when I click on run, the status screen shows it stalling at about 20% on the indicator bar.


      The file is only 12 Meg, so after a few minutes I went to the task manager and cancelled the installation.  Rebooted the machine, and it comes up okay, but the RST service doesn't run, which means that my Raid 1 isn't functioning.


      Tried this a couple of times, with no success.


      My computer is a Dell XPS9100. Other than the RST issue, Windows 10 functions great.


      Because the installation hasn't been completed, does that mean that future installation attempts don't work because it thinks the first one is still in progress?

      Any other way to install the drivers (safely?)  If I go into the device manager and try to update the drivers from there, using a web search, Windows says they are already the latest.


      I also tried running the driver update utility to let it search for drivers, and it doesn't find anything.

        • 1. Re: Windows 10 RST driver update stalls
          allan_intel

          I would like to check if the version 14.6 is compatible for your computer components.

          Please provide the chipset type or the processor model on your computer.

          On Windows 10

          Click on the Windows icon, and search for "System"

          Look for System Control Panel then note the processor model.

           

          Allan.

          • 2. Re: Windows 10 RST driver update stalls
            rayjcar

            The processor is an Intel Core i7 cpu 930 2.8 GHz

             

            A couple of other things I've determined.  If I go to device manager, disk drivers, it shows Intel Raid 1 volume. Properties says it's working properly.  Drivers are shown as up to date. 10.0.10240.16384

             

            Events says:

             

            Device SCSI\Disk&Ven_Intel&Prod_Raid_1_Volume\4&37008a6&0&020100 could not be migrated.

            Last Device Instance Id: IDE\DiskARRAY01.0.00__\4&37008A6&0&0.1.0
            Class Guid: {4D36E967-E325-11CE-BFC1-08002BE10318}
            Location Path:
            Migration Rank: 0xF000FC00FFFFF120
            Present: true
            Status: 0xC0000719

             

             

            Going to Storage Controllers shows Intel Express Chipset SATA Raid Control.  Drivers up to date. 13.2.0.1022

             

            Events says:

             

            Device PCI\VEN_8086&DEV_2822&SUBSYS_04821028&REV_00\3&11583659&0&FA was migrated.

            Last Device Instance Id: PCI\VEN_8086&DEV_2822&SUBSYS_04821028&REV_00\3&11583659&0&FA
            Class Guid: {4D36E97B-E325-11CE-BFC1-08002BE10318}
            Location Path:
            Migration Rank: 0x0
            Present: true

             

            The system boot is the raid array, so the fact that the machine still boots up, and during the boot sequence recognizes the 2 drives, suggests that the Raid is functioning.  I just have no way of monitoring or controlling it.