4 Replies Latest reply on Sep 20, 2015 10:22 AM by AlexT_Intel

    Setting up board again...

    KurtE

      Sorry, I am a bit rusty with my Edisons...

       

      I decided to try out an Edison in the Trossen Robotics HR-OS1 as I know that some others are using it...

       

      So reflashed to what I think is the latest image

      root@Edison-HROS1:~# uname -a

      Linux Edison-HROS1 3.10.17-poky-edison+ #1 SMP PREEMPT Fri Jun 19 12:06:40 CEST 2015 i686 GNU/Linux

       

      I plugged in the Arbotix-pro which uses FTDI and the tty device (/dev/ttyUSB0) does not show up.  I remember I needed to

      Add it from Alex's repos, which I have configured, but if my memory is correct it probably needs an updated kernel.  I thought one of the more

      recent images was such that the Unames would be the same?

       

      I tried using the steps from: http://alextgalileo.altervista.org/blog/install-kernel-from-repo-onto-edison-official-image/

      And I probably did something wrong as the board would not boot, flashall did not work.  Flashall --revovery said it recovered, but sill

      did not work.  But Flash Lite app on the PC worked on second attempt.  First attempt was running real real slow and then failed.  I think

      maybe because I was using USB3 connection.  So tried agin on USB2 connection and it worked...

       

      So I am back to where I was.

       

      Question is, should I follow those instructions again?  Or should I flash my own build?  Or are there newer builds that have the FTDI as part

      of it?

       

      Again Sorry if I missed something obvious.  But as I said I am rusty.

       

      Kurt

        • 1. Re: Setting up board again...
          CMata_Intel

          Hi Kurt,

           

          I'm guessing you are trying with: kernel-module-ftdi-sio

          If you ran in the latest image opkg info kernel-module-ftdi-sio you will see that is not installed. If you try to install it with opkg install you will receive the error message related to space in the device.

          You should try with a custom build, mhahn show the steps for this module here: adding FTDI_USB to Edison kernel

           

          Regards,

          Charlie

          • 2. Re: Setting up board again...
            KurtE

            Thanks,

             

            Yep - It is uninstalled, so I do the opkg install.  I do not get the out of space error as I made sure the boot segment was big enough following AlexT_Intel instructions on how to install a new kernel (How to install a kernel from my repo onto Edison with the official image).  I keep these instructions (step 3) in my cheat sheet: Wish there was a Wiki and/or Sticky Posts and/or FAQ and/or ...

             

            However even after installing this module it still does not load.   Again I believe it is due to the differences in the names of the Kernel for the downloaded image (3.10.17-poky-edison+) and the built kernel which if I remember correctly is: 3.10.17-yocto-standard

             

            Right Now I am in the process of doing a build.  I decided to do it again from scratch as maybe I am lucky and it will pick up some new stuff.

             

            Also mean to look to see if there are any new instructions on how to build using the sources that are up on github.

             

            Thanks again

            • 3. Re: Setting up board again...
              KurtE

              Quick update: It appears that my built image is now properly installing the FTDI driver.  I did this by building my own image using the build guide:

              http://download.intel.com/support/edison/sb/edisonbsp_ug_331188007.pdf

               

              Note: the guide could use some editing.  The current sources layout appears to be different than what is shown in the guide.  Things like where the

              source poky/oe-init-build-env

               

              Is located... Also where the post build shell script is...

               

              Also you may want to put reminder in different places that when you are trying to flash your edison you may need to run it using sudo.

               

              Also: as I mentioned the built image has a different name:  3.10.17-yocto-standard

               

              I still wish that the images that are downloaded for the Edison and the ones we build have the same name, such that the drivers like the FTDI driver work from Alex'ts repo.  Better yet I wish that this driver was built in to the default image

              • 4. Re: Setting up board again...
                AlexT_Intel

                Generally speaking, the solution is the same as it was before, i.e. to first install the kernel from my repo, then install the module. The reason is indeed that naming difference, which should be fixed at some next release, because I've reported it internally and AFAIU it was fixed. I have no idea when the release is going to happen, if you ask me.

                 

                And nowadays the best way to start from scratch if Flash Tool Lite, not the flashall.bat/.sh, as you've found out by experimenting.