4 Replies Latest reply on Sep 21, 2015 9:58 PM by darwinb_intel

    NUC5i3RYK and USB 3.0

    mldenison

      I've had this NUC up and running for around a month now.

       

      The only issue I have is compatibility/reliability with USB 3.0 devices.

       

      I have tried to connect a SATA BluRay burner installed in an external SATA to USB 3.0 case.  When plugged into any USB port on the NUC, I usually get an unrecognized USB device message.  The next day, it might connect fine but, during the day, the message will pop up again with the unit just sitting there.

       

      I have exactly the same issue with a Samsung M.2 250GB drive installed in a portable SATA to USB 3.0 case for archiving purposes.

       

      I purchased a 4 port USB 30 powered hub to see if it were a power issue with exactly the same results.

       

      Both these units work flawlessly on my regular PC.

       

      I see, by using Google, that these issues have been a problem for well over a year.

       

      I cannot tell if this is a hardware  design defect, a firmware flaw or an Intel driver issue.  I'm running the latest BIOS and Intel USB 3.0 drivers.

       

      Is there any Intel support talk or news of a possible fix?

        • 1. Re: NUC5i3RYK and USB 3.0
          mldenison

          I have a work around.

           

          I've connected both of my optical drives to my hub using a USB 2.0 cable.  Both drives are now working correctly and do not produce a random unrecognized device error while the NUC is powered on.  And the USB hard drive, using a 3.0 cable, not longer disconnects randomly.

          • 2. Re: NUC5i3RYK and USB 3.0
            darwinb_intel

            Hello,

             

            I have a couple of questions for you:

             

            Is the Blue Ray drive a native USB3.0 unit from factory or it is an internal SATA drive that you installed in a SATA-to-USB3.0 external enclosure?

             

            You said that you tried a Samsung M.2 drive through USB3.0. This means that you are using an external M.2-to-USB3.0 enclosure, is that correct?

             

            If the answer is yes for both questions the common fact that I see is that you are using enclosures to connect to USB3.0. There is a big possibility that this is a compatibility problem with the enclosures or that the USB3.0 controller of the NUC is not identifying the devices properly due to the conversion from SATA to USB3.0 and M.2 to USB3.0.

             

            I know that you already found a work around but it will be good idea to test native USB3.0 devices to compare the results.

             

            In any case it won’t be bad idea to have the NUC drivers and BIOS up to date.

             

            The latest BIOS (v0350) for this unit can be downloaded using the following link:

            https://downloadcenter.intel.com/download/25228/BIOS-Update-RYBDWi35-86A-

             

            For safe BIOS update instructions visit:

            http://www.intel.com/support/motherboards/desktop/sb/CS-034522.htm

             

            To download the latest drivers visit the following URL, select “Drivers” under “Download type” and pick the operating system version you are using;

            https://downloadcenter.intel.com/product/83256/Intel-NUC-Kit-NUC5i3RYK

            • 3. Re: NUC5i3RYK and USB 3.0
              mldenison

              The Bluray burners are SATA units installed in Chinese eBay SATA to USB 3.0 enclosures.  I've since ordered and connected the same type hardware but as a complete package from a company called Pawtec in CA (from eBay).  That drive works fine using USB 3.0.  Apparently there's an issue with the Chinese USB 3.0 chipset in the first enclosures I ordered although they're fine using USB 2.0 cables.

               

              You are correct concerning the M.2 drive in an external enclosure.  That, too, is working fine now with USB 3.0.

               

              I'm running the latest available BIOS and USB drivers from the website.

               

              I've ordered another enclosure from Pawtec in hopes that the other Bluray burner will work using USB 3.0.

               

              I don't have any native USB 3.0 burners to connect with - too much money invested in enclosures that are not so sweet. :>)

               

              Thanks for the reply.

              • 4. Re: NUC5i3RYK and USB 3.0
                darwinb_intel

                Hello Mldenison,

                 

                Thank you for the information.

                 

                I hope the new enclosure works better.

                 

                Keep me posted.