3 Replies Latest reply on Nov 6, 2015 12:46 PM by allan_intel

    BSOD AND SLEEP problem possibly caused by GpioVirtual Controllers in Lenovo Yoga Tablet 2

    IK-Sector

      Good Day, I have a Lenovo Yoga Tablet 2 10.1inch that came with Windows 8.1 with Bing. I started experiencing BSODs ("DRIVER_IRQL_NOT_LESS_OR_EQUAL) right from the first day I got it. It also refuses to wake from sleep mode after sleeping for about 10minutes or more. I have to do a kind of soft reset to get it back on. These 2 major issues happens about 3 to 5 times in a day. I upgraded to Windows 10 and installed all relevant updates along with manufacture's drivers obtained from Lenovo website. Yet no progress.

      I decided to wipe the upgraded installation and do a clean install of Windows 10 with all relevant updates and drivers. But problems still persist.

      I got a tip from a fellow owner with same problems and was advised to reset DISPLAY SETTINGS to

      [Screen Off= Never; Sleep= Never]both on battery and plugged in, so that I have to put it to sleep-mode manually.

      This reduced the number of times it froze during SLEEP significantly. But the CRASH N REBOOT still persists.

      Please can anyone help me with these problems?

       

      Attached are crash dump files I got recently.

       

      First one is from blue screen crashes without VERIFIER.EXE running.

      Second is from crashes that occurred while running VERIFIER.EXE.

      Verifier reported a GpioVirtual Controller Driver as the problem device, so I uninstalled it. After the uninstallation, Verifier still reported some other Gpio Controllers as problematic.

      I went ahead and uninstalled all of them.

       

      Good thing I observed is that the BSODs during normal use stopped. Freezing during sleep mode also stopped.

      But something weird happened, after sometime the crashes and sleepmode freezes resumed. I checked device manager and discovered an 'UNKNOWN DEVICE' appeared.

      Each time I remove it, the problems will stop. Then somehow the UNKNOWN DEVICE reappeares again and the problems all come back.

      Please is there a possible solution to all these issues?