14 Replies Latest reply on Jan 28, 2016 3:15 AM by Baud43

    Remote Keyboard


      I cannot get the Intel Remote Keyboard to install on my compute stick. It is Windows 10 and keeps asking for the Media Creation Tool which I have installed. It could be looking for the Windows 8.1 version of Media Creation tool which does not install on Windows 10.

      Any ideas?

        • 1. Re: Remote Keyboard

          Hello blonn,


          You can try with BIOS update, here are the instructions Intel® Compute Stick — BIOS Update Instructions and then give it a try with the Intel Remote Keyboard.


          Let me know your findings





          • 2. Re: Remote Keyboard

            Hi Amy,


            No luck. The link the installer gives me takes me to the windows 8 version of the media creation tool. This does not install on Windows 10, there is another win10 version of the media creation tool. Does the installer know what to look for?



            • 3. Re: Remote Keyboard

              Hi blonn,


              Not sure what might be happening on your system... i have the Remote Keyboard installed on a Compute Stick with Windows 10 in my lab, so I know that it should work ok. Let's try to identify what's different on yours -


              - What is the SA# of your Compute Stick (on the label on the back)

              - At what point during the Remote Keyboard software installation does the error occur?

              - Is your Windows 10 version an 'upgrade' from Window 8.1 - or - is a 'clean' installation of Windows 10?

              - Are you trying this with the latest version of the Remote Keyboard software - at Intel® Download Center?



              Lois H.


              • 4. Re: Remote Keyboard


                SA# H69761-103

                Straight after it unpacks. i.e. gets to 100% then it brings up a window saying "Media Feature Pack Required"

                It was installed using the Media Creation Tool and an external USB. So clean.

                Yes latest version, just downloaded and tried again.

                • 5. Re: Remote Keyboard

                  Thank you... I checked with the engineering team - they did not ever see such an error during testing. So, I need to figure out how to reproduce this for them. Let me get some more details from you...


                  - Does everything else in Windows 10 appear to be working as expected?

                  - What BIOS version do you have installed?

                  - How much free hard drive space is there?

                  - What is the path/folder where you have the Remote Keyboard installer package?

                  - Can you take a screenshot of the error and post it?

                  - What happens if you right-click on the filename IntelRemoteKeyboardInstaller_32bit.exe and choose 'Run as administrator'? Same error?



                  • 6. Re: Remote Keyboard

                    Yes everything seems fine. There has been a Power state error a couple of times though.

                    See capture2 for Bios. But I just updated it.

                    12GB of space.

                    The installer was in Downloads. I have tried it from the desktop and c:

                    No difference when run as administrator.


                    • 7. Re: Remote Keyboard

                      Hi - this helps! I found a link to the Media Feature Pack for Windows 10 here - Download Media Feature Pack for N and KN versions of Windows 10 from Official Microsoft Download Center. Please try downloading and installing that, then try the Remote Keyboard installer again and let me know the results.

                      • 8. Re: Remote Keyboard

                        i found that link earlier  and have already installed it, when I try to install again it is says that it is already installed. I have checked the..dll files are in system32 as well.

                        still the same error appears.



                        • 9. Re: Remote Keyboard

                          Well, rats.


                          The Remote Keyboard software requires Microsoft .NET Framework 3.5, but the installer should take care of installing that. Perhaps this error is somehow related to that. What other software programs do you have installed on this Compute Stick... could something be interfering (like a virus checker)?

                          • 10. Re: Remote Keyboard

                            .NET is version 4.6. I will keep trying things. There is not much installed. Only Google apps and Smartboard software. It is used to run a classroom.


                            I will keep playing, hoping I don't have to do a reinstall. I wonder if it is because I did a new install. if you upgrade the Media Feature Pack is transferred across while a clean install doesn't. Mouse without borders is working at the moment but I would rather the students were able to control it. Bit of a shame as the Compute stick would be a good solution in schools.



                            • 11. Re: Remote Keyboard

                              Hi Bryan,


                              I'm still unable to reproduce this issue, but I've gone ahead and forwarded all the information you've shared to our software team for investigation.



                              • 12. Re: Remote Keyboard

                                Hi Bryan,


                                Just wanted to update you on this issue - unfortunately, none of us here at Intel have seen this error when trying to install the Host App.


                                However, a new Host App version (1.5.0) is about to go live in Download Center. While there isn't a fix for your specific issue, they did address a different Windows security certificate problem (not sure if that is related or not).  As soon as you see the new version at Download Intel® Remote Keyboard Host App, could you download and test it?


                                I'd also like to suggest you be sure you've allowed Windows 10 to install all its updates.


                                Let me know what happens with v1.5.0.




                                • 13. Re: Remote Keyboard



                                  IDENTICAL issue here....


                                  Windows 10 (the latest version), i have no way of loading the software, it complains about it needing "Media Feature Pack Required", i found a Microsoft link for the WIndows 10 version  here "Download Media Feature Pack for N and KN versions of Windows 10 from Official Microsoft Download Center", this loaded but the Intel keyboard software is still asking for the some install so it appears Intel is looking for something in the system that is NOT the media feature pack.


                                  I will add, i did see the tiny "remote keyboard" icon when i first upgraded to Windows 10 (from the 8 installed), but after a reboot it vanished and never came back, this was BEFORE i tried to load the Remote Keyboard.


                                  So is there a problem with Windows 10, i understand you cant replicate the issue, however as both of us here have the issue, and i have seen other on the internet with the same problem there is a problem here.


                                  I am NOT using WiFi, i do have a StarTech external USB network card and i do have BlueTooth on.

                                  • 14. Re: Remote Keyboard



                                    Same issue as above for me : many security warning messages when downloading the 32bits version of Remote Keyboard host app (v1.6.0.0), and after discarding them, installer shows several strange messages :

                                    - First warning : "Intel Remote Keyboard is currently running. Would you like to close Intel Remote Keyboard and continue?" > this is my very first installation, so ...!?

                                    - Second dialog : Media Feature Pack Required ... with a download link that is not working.


                                    After reading comments above, I didn't even try to install this Feature Pack, but I wanted you to know that the issue is not that rare ...

                                    My host system is a DELL Venue Pro 8 tablet with Windows 10 installed and up-to-date.

                                    The virtual keyboard takes so much space on a 8" screen that I'm really impatient to be able to use my iPhone as a keyboard


                                    Thank you for your help