3 Replies Latest reply on Sep 24, 2015 12:50 AM by Cesar Badilla

    Intel NUC D34010WYKH2 @ UHD/30hz not working

    Möhre

      Hi,

       

      I cannot use 3840x2160@30hz with my Intel NUC D34010WYKH2.

      The NUC is connected via DP -> HDMI cable. I am running Ubuntu 14.04 LTS where all resolutions beyond FHD are not listed. Using xrandr I can see support for UHD. All modes up to 25hz are working fine. 30hz fails with xrandr: Configure crtc 0 failed. (60hz too - but I am not sure if it is supported with that NUC.) I already bought another cable where the manufacturer guarantees for 4k support @ 60hz.

       

      Any suggestions?

        • 1. Re: Intel NUC D34010WYKH2 @ UHD/30hz not working
          jasonNUC

          Hi Mohre,

           

          Have a look at this thread:Ubuntu Forums

           

          This user seems to have solved it for a somewhat similar situation.

          • 2. Re: Intel NUC D34010WYKH2 @ UHD/30hz not working
            Möhre

            Well, I did more or less the same, but could not solve the problem. The xrandr lines I use (retrieved via gtf) are:

             

            "3840x2160_24.00"  266.58  3840 4048 4456 5072  2160 2161 2164 2190  -HSync +Vsync  --> OK

            "3840x2160_25.00"  278.70  3840 4056 4464 5088  2160 2161 2164 2191  -HSync +Vsync  --> OK

            "3840x2160_30.00"  339.57  3840 4080 4496 5152  2160 2161 2164 2197  -HSync +Vsync  --> Configure crtc 0 failed

            • 3. Re: Intel NUC D34010WYKH2 @ UHD/30hz not working
              Cesar Badilla

              Hello Möhre,

               

              You may try adding a new mode that is not  displayed as supported by  using  xrandr to make sure that the new mode can fit within the maximum framebuffer size:

               

                  user@computer:~$ xrandr | grep maximum

                  Screen 0: minimum 320 x 200, current 1440 x 900, maximum 1680 x 1680

               

              Use gtf to create a mode line;

               

                  user@computer:~$ gtf 1440 900 59.9

               

                  # 1440x900 @ 59.90 Hz (GTF) hsync: 55.83 kHz; pclk: 106.29 MHz

                  Modeline "1440x900_59.90"  106.29  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync

               

              Add new mode by using xrand:

               

                  user@computer:~$ xrandr --newmode "1440x900_59.90"  106.29  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync

               

              Copy the text after Modeline from the above output as is and paste it after the --newmode option in xrandr.

              Add this newly added mode to the desired output (VGA/LVDS etc)

               

                  user@computer:~$ xrandr --addmode VGA 1440x900_59.90 as my monitor is connected via VGA, i will add this new mode to VGA

               

              Choose the new mode:

               

                  user@computer:~$ xrandr --output VGA --mode 1440x900_59.90

               

              If everything is fine after following the above steps your display should switch to the new mode.

               

              Additionally you may get relevant information here Patching screens EDID information

               

              Please take into consideration  the supported resolutions for Intel NUC D34010WYKH2 are:

               

              Single Display HDMI -> 1920 x 1200 @ 60 Hz

              Dual Display DisplayPort and HDMI-> 3840 x 2160 @ 30 Hz (DisplayPort) 1920 x 1200 @ 60 Hz (HDMI)

              Single Display DisplayPort-> 3840 x 2160 @ 30 Hz

               

              Note: Higher resolutions may be achievable but have not been tested on Intel NUC.


               

              Regards,

              Caesar B.