1 Reply Latest reply on Nov 11, 2009 2:59 PM by speedracer

    DQ45EK Does not work with video cards

    speedracer

      Hello.  I recently purchased a couple DQ45EK motherboards and I am trying to use discrete PCI express videos cards on them.  I have tried using four PCI-e video cards and none of them work.  What happens is that the motherboard defaults to the integrated Intel 4500 video and I do not get video from the discrete video card.  I am using the latest BIOS version 0101.  Here are the video cards I have tried:

       

      PCI-e x1

      PNY NVIDIA Quadro NVS 290d

       

      With PCI-e x16 to x1 converter:

      PNY Nvidia Geforce 9500  GT

      MSI ATI Radeon 4350

      MSI Nvidia Geforce 9500 GT

       

      I have set the BIOS to use an external PEG adapter, but that does not make a difference.  The auto setting does not work as well.  Running lspci in Linux shows that the video card is attached, but that's about all.  I have tried using all of these video cards on a PCI-e x1 slot on a MSI P45 Platinum motherboard and they all work flawlessly.  I also tested the PCI-e slot on the DQ45EK with an Intel gigabit ethernet adapted and it worked perfectly.  It's just video that's a problem.

       

      Any help getting a PEG adapter working would be appreciated.

        • 1. DQ45EK Does not work properly with PCI express video cards
          speedracer

          After a bit of testing, I found out that the DQ45EK does not disable the integrated video or set the integrated video as a secondary device when there is a PCI-express video card present.  Changing the BIOS settings makes has no effect.

           

          (--) PCI: (0:0:2:0) 8086:2e12:8086:1004 Intel Corporation 4 Series Chipset Integrated Graphics Controller rev 3, Mem @ 0xd3400000/4194304, 0xb0000000/268435456, I/O @ 0x0000e220/8
          (--) PCI: (0:2:0:0) 10de:0640:196e:0643 nVidia Corporation G96 [GeForce 9500 GT] rev 161, Mem @ 0xd2000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288
          
          
          

           

          By default there is no video output in Karmic.  In fact, X does not start. I was able to get video out of my GeForce card to work in Kubuntu Karmic, but it was in multihead mode and I was not able to disable the integrated x4500 adapter.

           

          I tried to downgrade my BIOS version to see if it was a new bug, but it failed when trying to flash the management firmware.  I guess downgrades are not allowed on this board.  The recovery method also did nothing.  Nothing showed up on the screen.

           

          Intel, is there a beta BIOS available that I may try?  Is there a fix coming out soon?  This bug makes it impossible to use a graphical bootloader, and you only get video on the PCI-e adapter once the O.S. loads up.  And that's only if one can figure out how to setup a secondary adapter.  I have yet to see how this bug affects Windows.