3 Replies Latest reply on Sep 18, 2015 4:28 AM by xthunderheartx

    latest Galileo SD image and sshd

    shazz

      Hi,

       

      I have just written the latest iot-devkit-latest-mmcblkp0.direct to my Gen2 board, my serial link (not USB) is working, the board has an IP address but I did not find how to setup the sshd service ? There is not rcX.s or daemonized scripts anywhere to start the ssh deamon. Any idea ?

       

      Thanks !

       

      shazz

        • 1. Re: latest Galileo SD image and sshd
          PabloM_Intel

          Hi shazz,

           

          Have you checked the sshd@.service found here: root@galileo:/lib/systemd/system#, under your Galileo? I would suggest you to read that file and see if that’s what you’re looking for.

           

          Regards,

          PabloM_Intel

          • 2. Re: latest Galileo SD image and sshd
            shazz

            Hi Pablo,

             

            Yep I saw there was a systemctl service :

            root@galileo:/dev/cpu# systemctl list-unit-files *sshd*

            UNIT FILE           STATE

            sshd@.service       static

            sshdgenkeys.service enabled

            sshd.socket         enabled

            But I have to clue how to enable it :

            root@galileo:/dev/cpu# systemctl enable sshd@

            The unit files have no [Install] section. They are not meant to be enabled

            using systemctl.

            Possible reasons for having this kind of units are:

            1) A unit may be statically enabled by being symlinked from another unit's

               .wants/ or .requires/ directory.

            2) A unit's purpose may be to act as a helper for some other unit which has

               a requirement dependency on it.

            3) A unit may be started when needed via activation (socket, path, timer,

               D-Bus, udev, scripted systemctl call, ...).

            I don't know systemctl... maybe that's why

            • 3. Re: latest Galileo SD image and sshd
              xthunderheartx

              You don't need to do anything. The ssh daemon is started by default and runs on the standard port.  You should be able to "ssh root@yourgalileoaddress" and get busy.