3 Replies Latest reply on Apr 21, 2016 10:09 AM by allan_intel

    Warning for those thinking of upgrading Windows 10 with First Gen Intel Graphics HD

    Loseyourself

      Many users like myself are still using First Generation Core processors with First Generation Intel HD Graphics on Windows 7. Performance of the CPU is still sufficient enough these days not to warrant an upgrade to a current processor but for many who have laptop systems without discrete graphics and are using the Intel HD Graphics, consider this a warning. The drivers included with Windows 10 - 8.15.10.2900 11/26/2012 are not fully compatible.

      I've tried multiple different versions of the driver by setting Windows 10 in test mode and adjusted the .inf to support installing different versions of the driver but .2900 is the 'best' version. Drivers older than .2900 have even more issues including rendering artifacts.

      The driver has severe performance issues, crash upon returning from standby or the monitor powering down. Video playback is pixelated and drops frames regardless of the playback software. There is also video tearing when using Chrome, Firefox or Spartan. The tray effects also lag.

      With just over a month to go till Windows 10's release, a lot of people are going to be getting their upgrade notifications and reserving their upgrades but will be very disappointed when they have to revert back to Windows 7 because of the state of the graphics drivers.

      The drivers are not going to be upgraded according to Intel as they are considered 'Legacy'.

      https://communities.intel.com/thread/45864

      http://www.intel.com/support/graphics/sb/CS-034343.htm?wapkw=cs-034343


      With Windows 10 now out, I can confirm that the Intel drivers still do not work properly. Returning from standby or monitor power down will result in the driver crashing. Video playback rendering lag and tearing is still present despite low cpu usage.

      Performance can be significantly improved by turning off transparency effects: Settings -> Personalization -> Colors -> Turn off "Make Start, taskbar, and action center transparent"