5 Replies Latest reply on Sep 10, 2015 1:50 AM by barlesh

    Use UART1 (rx/tx pins 0,1) of edison with arduino board

    barlesh

      hallo friends

      (sorry for my bad English, and also being a bit green with Linux )

       

      I want to connect my Edison - Arduino to other modem using serial communication via pins 0,1.

      The final goal is to talk to it with a c program (mraa lib), but for now, I try to check that communication is set.

       

      I have a TTL-TO-USB convertor CP2102 based, connecting between my Edison and my PC.

      I connected it like that:

      (Arduino) pin0 (RX)   --->  (CP2102) TX

      (Arduino) pin1 (TX)   --->  (CP2102) RX

      (Arduino) GRD (RX)   --->  (CP2102) GRD

      (at the begining I also connected (Arduino) 5V (RX)   --->  (CP2102) +5V but it wake the Edison, leds started to blink, so I understend the Edison dont need to power the CP2012 MODULE, the pPC does that)

       

      My PC recognize the new connection as ttyUSB0 (figured it out by dmesg), just like the standrart connection (UART2).


      From there, I used this discussion

      How to enable PIN0/PIN1 for UART usage (TX/RX)

      according to the answer at the discussion, I configured pins mode to UART.

      Then, I wanted to set getty to run at boot, so I can  login to Yocto, just like I do with UART2.

      I tried to edit /etc/inittab only to find out it doesnt exist. (/dev/ttyMFD1 doesnt exist as well). so I created the file with the line

      T1:23:respawn:/sbin/getty -L ttyMFD1 115200 vt100 , to set getty at startup.

       

      Then I hooked the USB to my PC (which recognized it), and plugged Edison to electricity, but nothing happened.

      I got the Edison from a friend, so I’m not sure what is the Yocto version (tried configure_edison --version but it says the command doesn’t exist).

       

      Any suggestions? the getty is not that important, if you have other (simpler) way to check the serial connection, or maybe other tutorial I haven’t found,  I'll be glad to hear.

      Thank you very much

      Bar