1 2 3 Previous Next 38 Replies Latest reply on Apr 18, 2016 1:37 PM by J.Side_Kick

    Intel 750 SSD Failure on System Resume

    pc_tuner

      Hi there, I recently purchased an Intel 750 SSD (2.5 inch drive, model number SSDPE2MW400G4R5) and am having some major issues with getting it to run smoothly. I originally had it as a boot drive for Windows 10 on a newly purchased Gigabyte GA-Z170X-Gaming G1 Motherboard. Everything with the installation went smoothly. The drive was connected to the motherboard via the M.2 to U.2 Add-in-Card. My experience was fine until attempting to resume from the sleep or hibernation state on my computer. Except for a few random instances, the SSD failed to resume the system from sleep and would eventually give up and restart the system altogether. Specifically, my monitors would show nothing and have no display signal, further my mouse and keyboard would quickly disconnect (after waking the computer) and stay disconnected. However, The computer fans would turn on along with all interior lights and stay running. After auto-restarting, I would then be greeted with a blue screen of death with the error message "INACCESSIBLE_BOOT_DEVICE". After the next restart (due to the BSOD), the system would then boot fine, usually taking me to the state where i had originally left the computer when it was slept. Attempting the hibernation state would cause the same error (INACCESSIBLE_BOOT_DEVICE) to appear which would then cause a restart which (after automatic windows repair at the splash screen), would load where i left off at before hibernating the computer. The ensuing hours were then dedicated to trying to find the root cause of the problem. I'll briefly summarize the actions (that I can remember) taken below:

       

      • Downloaded Intel SSD Toolbox and ensured all drivers were up to date.
      • Uninstalled and reinstalled intel ssd drivers along with various others such as nvidia display drivers.
      • Changed Power State options to high performance, and changed the hard drive turn off option to "never"
      • Downloaded the latest (non-beta) BIOS version for Motherboard. Specific version ID was changed from F2 to F3  (Full hardware info will be provided below)
      • Ran Windows Memory Diagnostic Test, which came back with no errors on the RAM.
      • Ran Full Diagnostic Test on SSD through Intel SSD Toolbox, which came back with no errors.
      • Re-checked for any loose connections within computer case.
      • Uninstalled various non-core programs, and closed non-critical processes before attempting to sleep. Most likely coincidental and non-repeatable, I actually did get the system to resume a few times from the sleep state doing this method. However, after restarting and closing out the same programs and processes, I could not replicate the result. A couple hours of attempts and I gave up on this path.
      • Uninstalled windows 10 altogether and reinstalled Windows 8 cleanly. The issue still persisted in the hibernation and sleep state on windows 8 as well.

       

      At this point, I was out of ideas and decided that the best path forward was to put windows 10 on my SAMSUNG 840 EVO 500 GB to further isolate, confirm, and better diagnose the Intel 750 SSD and the drivers as the underlying issue. As a result, I disconnected all other hard drives/SSD's along with the Intel 750 SSD and installed Windows 10 on the Samsung SSD, I once again attempted the sleep and hibernation states multiple times and over several restarts after installing various programs and drivers. I did not have any issue occur once. The system resumed in roughly 7-10 seconds every time, without a problem.

       

      I now connected all my other storage devices to my PC to once again test for problems. First of all, the Intel 750 SSD was detected and accessible under my devices and drives. I then proceeded to test the sleep state once again without issue on multiple instances. However, the total time to resume from the sleep state increased to roughly 20-30 seconds. Further, the Intel 750 SSD was now no longer detected by windows. Checking Event Viewer lists two relevant entries occurring during system resume.

       

      1. Error at 12:54:59 AM at Source "stornvme" (event id 11): The driver detected a controller error on \Device\RaidPort2.
      2. Warning at 12:55:04 AM at Source "disk" (event id 157): Disk 4 has been surprise removed.

       

      At this point, I entered into Device Manager and disabled, and then re-enabled the "standard NVM Express Controller". This immediately caused windows to detect the ssd once again and fixed my issue (until the next sleep state is attempted). If anyone could provide any guidance to me on this issue it would be much appreciated. I do know that users have had similar issues with other M.2 SSD's not resuming from sleep state. One solution I've also read about is to disable link power management? However, I don't want to attempt anything else until I perhaps hear from someone with more experience on solving an issue like this. Thanks so much for reading this far, I'll provide a summary of my specs below, but please let me know anything else needed to help aid you all in solving this!

       

      Operating System

        Windows 10 Home 64-bit

        CPU

        Intel Core i3/i5/i7 6xxx @ 3.50GHz 23 °C

        Skylake 14nm Technology

        RAM

        16.0GB

        Motherboard

        Gigabyte Technology Co., Ltd. Z170X-GamingG1 (U3E1) 28 °C

        Graphics

        XB270HU (2560x1440@144Hz)

        VG248 (1920x1080@144Hz)

        VG248 (1920x1080@144Hz)

        TOSHIBA-TV (1920x1080@60Hz)

        NVIDIA GeForce GTX 980 (EVGA)

        NVIDIA GeForce GTX 980 (EVGA)

        ForceWare version: 353.62

        SLI Enabled

        Storage

        223GB SanDisk SDSSDHII240G (SSD)

        931GB TOSHIBA DT01ACA100 (SATA)

        223GB KINGSTON SV300S37A240G (SSD)

        931GB TOSHIBA DT01ACA100 (SATA)

        372GB NVMe INTEL SSDPE2MW40 (Unknown)

        465GB Samsung SSD 840 EVO 500GB (SSD)

        931GB TOSHIBA DT01ACA100 (SATA)

        Optical Drives

        HL-DT-ST BDDVDRW UH12NS30

        Audio

        Sound Blaster ZxRi

        • 1. Re: Intel 750 SSD Failure on System Resume
          jonathan_intel

          Hello Pc_tuner,

           

          You already tried many troubleshooting steps, like updating BIOS and making sure the connectors are plugged correctly, among other actions.

           

          As you mentioned, the first thing to do is to install the Intel® Solid-State Drive Data Center Family for PCIe Drivers, the latest version at this time is 1.2.0.1002. Please make sure you are using this version.

           

          Since the Diagnostic test in the toolbox finishes with no errors, this may be due to configuration. Please consider the following:

           

          - When booting from the Intel® SSD 750 Series, the settings required in the Motherboard vary depending on the model and vendor. Please make sure the BIOS Feature: Fast Boot is disabled, and that the OS and Boot features are set correctly. For reference, you can review the following document (this was created for motherboards with the X99 and Z97 chipsets):

           

          Intel® High Performance Solid-State Drives — Booting an NVMe* PCI Express* Solid State Drive

           

          - If the issue persists, try disabling Windows* Fast Startup and check if this solves the problem.

          • 2. Re: Intel 750 SSD Failure on System Resume
            pc_tuner

            Hi Jonathan, I confirmed I had the latest drivers for the intel 750 ssd via the link you provided and even uninstalled and re-installed them once again (on the intel boot drive) making sure all programs were closed during the installation. As it turns out, I forgot to install the official intel drivers for the ssd on the Samsung boot drive, however they were present on the Windows installation using the Intel SSD as the boot drive. Sorry about that, long night of troubleshooting made me forget that crucial step somehow. However, it would make no difference as this resulted in no change with the Intel SSD failing to be detected while on my current Samsung boot drive. Testing using the intel 750 SSD as the boot drive also showed no difference, with black screens eventually leading to the system restarting once more. Interestingly, the mouse and keyboard were connecting now and are lit up during the resume process but the system still does function.

             

            I then referred to the manual that you linked me and tried to discern the general settings to use on a z170 motherboard by looking at the set up requirements for the x99 and z97 Gigabyte chipset. Through this, I changed "storage boot option control" from "legacy" to "UEFI". To be clear other relevant settings (unchanged) were:

             

            Windows 8 features: Windows 8/10

            Other PCI Device ROM priority: UEFI

            Fast Boot: Disabled

            CSM: Enabled

             

            Attempting the sleep state once again yielded no change in result resulting in the SSD failing and being undetected.

             

            I also disabled Windows Fast Startup in the power options, and then proceeded to sleep my computer. When it powered back on, the Intel SSD was still present!!! Ah Jonathan, I thought you had fixed my problem for good, but i was sadly mistaken. Attempting to navigate into the SSD gave an error message stating that the chosen file path "was not inaccessible. The request failed due to a fatal device hardware error." I then tried disabling and re-enabling the driver which then forced a reboot of the system to re-enable the driver (this had not happened before). Trying the same method once again, this time showed no ssd. I then disabled and re-enabled the driver and it showed up once more and was fully accessible. One last time, I slept the computer again (still with fast startup disabled) and this time showed the intel ssd again. However, it was once again inaccessible and required a reboot to properly re-initialize the driver.


            Lastly, their were some new events of note in event Viewer (alongside previously mentioned ones in original post) with several repeating countless times in minutes. These include:

             

            1. Error at Source "IaNVMe" (event id 11): "The driver detected a controller error on \Device\RaidPort4."
            2. Error at Source "disk" (event id 154): "The IO operation at logical block address 0x476e0 for Disk 4 (PDO name: \Device\00000087) failed due to a hardware error." [MY NOTE: many of these errors occurred rapidly, at various block addresses]
            3. Warning at Source "Nfts" (event id 140): "The system failed to flush data to the transaction log. Corruption may occur in VolumeId: \\?\Volume{7e558c4a-ef96-4b8c-b6a4-5674c4a82e9f}, DeviceName: \Device\HarddiskVolume12. (The request failed due to a fatal device hardware error.)" [occurred numerous times]
            4. Error at "DeviceSetupManager" (event ID 131): "Metadata staging failed, result={E84DF2CA-4ACE-11E5-9BC2-806E6F6E6963} for container '0x80070490'" [occurred numerous times].
            5. Warning at "Kernel-PnP" (event id 219): "The driver \Driver\WudfRd failed to load for the device SWD\WPDBUSENUM\{4d4b97c7-4ad4-11e5-8257-806e6f6e6963}#0000000000100000." [I believe this occurred when i tried to re-enable the driver myself and it forcing a restart to work]

             

            How should i proceed further with this? Some bios configurations showed CSM being disabled but this was for older chipsets. Is there anyway, you could provide specific settings that you, or Intel recommends I should set with a with my specific z170 motherboard? Again, please let me know if you need further details from me! I'd like to get this sorted as soon as possible.     

            • 3. Re: Intel 750 SSD Failure on System Resume
              jonathan_intel

              Hello pc_tuner,

               

              Please use Intel® Solid-State Drive Toolbox, current version is 3.3.1, and obtain the SSD logs.

               

              This can be retrieved by clicking the Export button in the bottom–right section of the Toolbox home window.

              • 4. Re: Intel 750 SSD Failure on System Resume
                pc_tuner

                Hello Jonathan,

                 

                I attached the logs you asked for. Let me know if anything looks out of the ordinary to you!

                • 5. Re: Intel 750 SSD Failure on System Resume
                  jonathan_intel

                  I checked the log from the SSD, and it looks mostly OK, the drive does not have any SMART errors and it appears to be healthy.

                   

                  The most important finding is that it shows the drive is working in PCI Gen 1, when it should be Gen 3. This may not be related to the issues resuming from sleep, but is definitely something to look at:

                   

                  Current PCIe Link Speed     0x1

                   

                  I was checking the GA-Z170X-Gaming G1* User Manual, and we would recommend you to check with the motherboard vendor to check if they have any additional recommendations to configure the board and prevent this type of issues. Here are some aspects you might want to review with the Computer Manufacturer Support.

                   

                  - Which M.2 slot are you using to connect the SSD? Page 36 of the Manual indicates that the M2C_32G M.2 connector is preferred, since the M2B_32G M.2 connector will limit the SSD to x2 speed depending on the configuration.

                   

                  - Please review the BIOS - M.I.T - Miscellaneous Settings, in page 64 of the guide, it indicates that it is possible to limit the PCIe operation mode.

                   

                  - Check the information shown in the BIOS - Peripherals - NVME configuration. Let us know if you find anything abnormal, and if possible, provide the information shown in this tab.

                  • 6. Re: Intel 750 SSD Failure on System Resume
                    pc_tuner

                    Hi Jonathan, I am using the M2C_32G M.2 Connector on the motherboard and have nothing connected to the SATA 4 and 5 Ports since they do not work with the M.2 slot occupied. The Max link speed set in the BIOS - M.I.T - Miscellaneous Settings is set to the default "AUTO" setting and has not been changed by myself ever.

                     

                    Interestingly, my motherboard is no longer displaying information under the BIOS - Peripherals - NVME configuration. This is strange as I know it has displayed this information before for me. I tried restarting my computer and it still didn't display anything under this section. However, The Intel SSD is still being picked up by my computer under my SAMSUNG boot drive and is still an accessible and working boot drive by itself.


                    Another strange thing is that after seeing your post about the Current PCIe Link Speed being 0x1, I exported the SSD results once again and found that it was now 0x3. After sleeping the computer, having the drive not being detected and disabling and re-enabling the driver for the SSD the result now showed that the current PCIe Link Speed as being 0x1 once again. I have posted the two SSD logs relating to this below.


                    Any idea at all as to what could be causing this and if its related to my issue at all? Thanks so much for looking into this for me!   

                     

                    Further, I have opened a separate thread in regards to this issue on the Gigabyte forums (link is Intel 750 SSD Crash with Gigabyte GA-Z170X-Gaming G1 Motherboard) . I have also opened a ticket with Gigabyte support but as of yet have heard no response.

                    • 7. Re: Intel 750 SSD Failure on System Resume
                      jonathan_intel

                      Hello Pc_tuner,

                       

                      The PCIe downshift after sleep may be related to the main issue and we will perform additional research about this. We will provide further updates as soon as we have them.

                       

                      Please let us know if you receive any news from Gigabyte as well.

                      • 8. Re: Intel 750 SSD Failure on System Resume
                        pc_tuner

                        Okay, will do. Thanks for looking into this further.

                        • 9. Re: Intel 750 SSD Failure on System Resume
                          jonathan_intel

                          Hello,

                           

                          The information we have suggests that this is due to the design of the motherboard, or BIOS settings. We strongly advise you to check with Gigabyte if the Intel® SSD 750 was validated for your motherboard, and what are the recommendations from their side.

                           

                          It will be better to wait for the response and recommendations from the motherboard manufacturer. At this point, we can only provide some general recommendations:

                           

                          - Try booting the system  from the Intel® SSD 750 using a light-weight configuration. Leave only the CPU, single memory module, remove additional hard drives, embedded display adapter or single video card, keyboard and mouse connected. PCIe devices, such as video cards, may impact the link speed of PCIe drives. Using a single memory module will help you discard conflicts in the motherboard. Albeit SATA SSD's and other peripherals should not have an influence on the functionality, it will be useful to keep a basic setup, to help you exclude a potential root cause.

                           

                          - Check you BIOS settings related to PCIe, like Setting up Gen 3 speeds, also, it may have an option for POST delay that will give more time for the SSD to initialize. You might also explore power-related settings (disable power saving features, etc).

                          • 10. Re: Intel 750 SSD Failure on System Resume
                            pc_tuner

                            Hi Jonathan, sorry for the delayed response. I tried disconnecting all unnecessary hardware but the issue still persisted. Gigabyte replied back a week after opening the ticket asking the following:

                             

                            "It appears you have alot of drives installed onto the board, do you only experience this issue with the Intel 750 or with any other sata drives as well?

                            All other sata drives does not exhibit this issue?

                            If so, please provide us with more information such as did you applied any type of Windows updates upon completing OS installation and which drivers/software you had applied?"


                            To tell you the truth, I'm at the end of my rope trying to troubleshoot this one and decided to contact newegg for a refund on the SSD. Sorry you weren't able to fix this one for me, I know you tried your best! Please let me know, if Intel ever determines the potential root cause of this issue. Perhaps, another user will have a similar issue down the line and you'll be able to figure it out through them better.


                            All the best,


                            Dean

                            • 11. Re: Intel 750 SSD Failure on System Resume
                              jonathan_intel

                              Hello Dean,

                               

                              We would like to thank you for your effort in troubleshooting and for all the information you provided. This will help us investigate further about this issue.

                              • 12. Re: Intel 750 SSD Failure on System Resume
                                Omni_Gamer

                                Hey Jonathan and Dean,

                                 

                                I too am having the exact same issue with my newly installed 750 pcie drive. The drive itself works great, until you do anything related to sleep state. Then it just crashes the PC. I'm running on the x99 platform, and would like some insight if possible. Specs are as follows:

                                 

                                MSI X99 sli plus

                                i7 5930k

                                16GB DDR4

                                Windows 10 64.

                                 

                                -Matt

                                • 13. Re: Intel 750 SSD Failure on System Resume
                                  pc_tuner

                                  Interesting, that's now two other people I have heard from that have my issue. Another user on the gigabyte forum described having the same issue. I have now returned the SSD, but i'll be monitoring this thread. Best of luck fixing it Matt! 

                                  • 14. Re: Intel 750 SSD Failure on System Resume
                                    WalGam

                                    Hello,

                                     

                                    I just want to say that I have the same exact issue as the original poster.  On my Gigabyte Z170x-Gaming 5 motherboard, Windows crashes immediately after waking from a sleep state.  (Immediate hard freeze, followed by a blue screen of death - BSOD.  Reproducible 100% every time.).  This occurs *only* if Windows is installed on the Intel 750 PCIe SSD.

                                     

                                    On the same exact system, with no hardware changes, installing Windows on another drive (in my case, a SATA Samsung 850 SSD), resolves the problem.  The system sleeps and resumes without problem 100% every time.  This is true even if the Intel SSD 750 is still installed in the system.

                                     

                                    The issue seems to be using the Intel 750 SSD drive as the install drive for Windows.  If it is the install drive, Windows will have a BSOD immediately after resuming from sleep.  If any other drive is the install drive, the issue is resolved.

                                     

                                    Also, I have tried every single troubleshooting step of the original poster.  I even went so far as to change various BIOS settings that I thought could potentially be related to the issue with no luck.

                                    1 2 3 Previous Next