12 Replies Latest reply on Sep 2, 2016 11:22 AM by mikec_intel

    Can't install Intel(R) USB 3.0 eXtensible Host Controller drivers

    SAJCON

      Hi! I have an issue where I have a device that does not work as it should. And before I can say with hard evidence that the device is faulty I need to update my USB 3.0 eXtensible Host Controller drivers. Atm the drivers installed are the one that Microsoft provides(version 10.0.10240.16384). And I want to install the Intel ones just to see if that does any difference since it's Intel technology I think it might. (It says "Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)" atm and with the Intel drivers installed I think it just says "Intel(R) USB 3.0 eXtensible Host Controller" right? Might be wrong on this)

       

      So I went to the drivers section and there was many things to choose from. My main thing here seemed to be that I needed to figure out what kind of chipset family my computer belonged to. And after some investigation is looks like it's the 9 series. In my device manager above the USB 3.0 eXtensible Host Controller it even says "Intel(R) 9 Series Chipset Family USB Enhanced Host Controller" over the "Intel(R) USB 3.0 eXtensible Host Controller" and my motherboard for anyone who wants to know is a GA-Z97X-Gaming 7 and my processor is a i7 4790K if that helps.

       

      So I downloaded the fitting drivers for the 8/9 family series chipset called "Intel(R)_USB_3.0_eXtensible_Host_Controller_Driver_3.0.5.69.zip". The problem is then I've extracted the zip files it says that my computer does not fit the minimum requirements to install this driver. I tried changing the admin rights for it and it's compatibility settings but I just got that message all the time. So I tried to install every other USB 3.0 eXtensible Host Controller driver I could find and it says the same thing. So I then had to do something else and tried to install the "Intel® Chipset Identification Utility" to really find out what chipset I have BUT when I try to install that it says I need to be on a admin account and give the installation admin rights. I AM on the only admin account on my computer AND I have given the installation file admin rights through properties as well. So no luck there either.

       

      And now I'm stuck. I've searched for almost 2 days in the Intel forums and across the web without becoming any smarter. Any drivers on the Gigabyte website for my motherboard does not seem to do any difference about this. I might also add that I'm on windows 10 x64.

       

      If anyone can point me towards the drivers I actually need to install for my Intel(R) USB 3.0 eXtensible Host Controller that'd be great!

       

      EDIT: I've found out that there is no intel drivers for the USB 3.0 eXtensible Controller for windows 10. Only for windows 7...... hopes this helps anyone reading this.