6 Replies Latest reply: Aug 3, 2010 11:44 AM by ali_asgher789@hotmail.com RSS

Problem with Intel PRO/1000 PL NIC on 802.1Q

tmm9527 Community Member
Currently Being Moderated

Hi everyone! It's nice to meet you here! I met a problem with Intel PRO/1000 PL NIC on 802.1Q and I use the Lenovo X60 laptop.

I installed the PROSet to enable the 802.1Q on my laptop. But it doesn't work.

 

The corresponding diagram is like below:

laptop--(hybrid+qinq)swith1(trunk)--(trunk)switch2(hybrid+qinq)--(trunk)switch3(access)--desktop

I couldn't ping to the desktop from the laptop. I got RTO from the CMD interface. I used wireshark to capture some packets from laptop and I found the laptop did send packets out but there's no corresponding 4 bytes for 802.1Q.

 

Another diagram:

desktop1--(access)switch1(trunk)--(hybrid+qinq)switch2(trunk)--(trunk)switch3(hybrid+qinq)--(trunk)switch4(access)--desktop2                                                    (trunk+SPAN)
                                                                       |
                                                                   laptop
 

I configured SPAN on switch2 and the destination port was the port which was connected to the laptop. The source port were other two ports respectively for each time.  I used Wireshark to capture packets on the laptop and there's no 802.1Q 4 bytes in those packets. But if I used another desktop3 instead of the laptop I could capture the packets with 802.1Q 4 bytes on the desktop3.

 

The 3rd diagram:

laptop1-------laptop2

Same VLAN is configured on both laptops. But those two laptops are not able to ping to each other successfully until the VLAN configuration was deleted on both laptops.

 

Thanks for your reading these words above patiently and any words from you will be highly appreciated.

  • 1. Re: Problem with Intel PRO/1000 PL NIC on 802.1Q
    tmm9527 Community Member
    Currently Being Moderated

    Hello! Is there anybody who can help me?! Thanks a lot!

  • 2. Re: Problem with Intel PRO/1000 PL NIC on 802.1Q
    MARK HANNA Community Member
    Currently Being Moderated

    Not sure why your back-to-back VLAN connection did not work. Maybe someone else has an idea.

     

    As for troubleshooting with Wreshark on the laptop, you need to set some registry entries before you can see the VLAN tags. My sniffer is not seeing VLAN, 802.1q, or QoS tagged frames describes the registry settings you need.

     

    Try uninstalling the network connections software and installing again from scratch. Make sure you install all the default components, because you won't get the VLAN tab unless Intel PROSet and ANS are installed. You might start by installing whichever version is supplied for your laptop. I'm not sure what changes might be made in the software by Lenovo. If you use the drivers that Lenovo supplies, you have the advantage of having the drivers they tested with your laptop.

     

    Another choice is to download the generic drivers from Intel. Your network connection uses one of the e1ennnn.sys drivers. Those drivers were just updated in the version 14.7 software package. I am not aware of any network connection software bug that would cause this, but if you are having a problem with the driver in the version 14.7 software package, you could try one of the older packages such as version 14.5. You can find both versions in Download Center. Just search on "network drivers" and choose your version of Windows from the filter boxes. Do not worry about not finding your network connection listed in the adapter list, the right driver is in there and should install without a problem.

  • 3. Re: Problem with Intel PRO/1000 PL NIC on 802.1Q
    ronrosenfeld Community Member
    Currently Being Moderated

    I don't know if this applies to you, but when I downloaded the latest PROset and driver (9.13.16.0) based on what the Intel Driver Update Utility told me I would need, it exhibited the same behavior.  I rolled back to the previous driver (9.6.31.0), using the tool in Device Manager, and all the functionality returned.  I subsequently did not see the PL variant listed as a supported NIC in the documentation.

  • 4. Re: Problem with Intel PRO/1000 PL NIC on 802.1Q
    tmm9527 Community Member
    Currently Being Moderated

    Thanks a lot!

    It works now.

    I created a registry dword named MonitorModeEnabled and value is 1 and then restarted the laptop.

    Finally I can capture packets with tags.

    Thank you very much!

  • 5. Re: Problem with Intel PRO/1000 PL NIC on 802.1Q
    tmm9527 Community Member
    Currently Being Moderated

    Thank you for your reply too.

  • 6. Re: Problem with Intel PRO/1000 PL NIC on 802.1Q
    ali_asgher789@hotmail.com Community Member
    Currently Being Moderated

    hi every one

     

    I have one problem with my Dell Optiplex 755 its with the on board lan card which is Intel 82566DM-2 it has the latest driver installed WIN32 version 9.13.16 as per intel website but its shows the error code 10 THIS DEVICE CANNOT START i have tried all the Opreating System from windows Xp to vista & windows 7 but the error is the same on all the OS although i have tried the dell diagnostics Utility with Bootable CD which detacts all the hardware problems but it passed all the test successfully is the any one who will advise me on this issue

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points