11 Replies Latest reply on Mar 26, 2010 2:40 PM by teddystacker

    BIOS update has hosed my system - now what?

    cgbick

      I updated the BIOS on my DG33SXG2 motherboard because I'm planning to upgrade to Win 7 64 bit from Vista 32 bit.  The BIOS I installed is DPP3510J.86A.0572, replacing DPP3510J.15A.0316.  The install seemed to work until Vista was running, then something happened and I got a restart required message.  Since then I get a blue screen when Windows is starting, just after the Intel BIOS screen.  I also get a message saying the AA number has not been set for the system even though it is in the BIOS.  I have tried several repair methods including restoring the entire disk partition but it still won't get past the blue screen.   What can I do to resolve this?

        • 1. Re: BIOS update has hosed my system - now what?
          Gize

          Sounds like you used a BIOS that is not meant to work with your mainboard.  The BIOS DPP3510J.86A.0572 is meant for Intel Mainboards--DP35DP, DG33TL, DG33BU, and DG33FB.  Your mainboard is supposed to use DPP3510J.15A.0316.  That's why it's probably griping about the AA number.

           

          The bluescreen issues and the original reboot request of Vista may be because it sees a different HDD controller or device ID (set as RAID or AHCI instead of IDE or vice versa).  You could try rolling through the different HDD settings in the BIOS and rebooting on each to see if it fixes your bluescreen.

           

          If not, I'd try and revert back to the proper BIOS: DPP3510J.15A.0316.  After some searching, I believe your system is a Gateway? If so, this would be the BIOS you need:  http://support.gateway.com/support/drivers/getFile.asp?id=21978&dscr=Intel%28r%29%20%28Schroeder%20Town%29%20G33%20Motherboard%20BIOS%20Update%20Version%20DPP3510J.15A.0316&uid=249765444

           

          Now, that file extracts to C:\cabs\9539753

           

          Typically you'd run the DPP3510J.15A.0316.EB.EXE file in that folder, assuming you're able to launch it out of Windows.  Since you're not, the only thing I can suggest is to try to recover the BIOS.

           

          Under C:\cabs\9539753\DOS  there is a file called DP0316P.BIO.  Burn that file to a CD.  All you need is that one file on the CD.

           

          That board has a very similar (if not the same) PCB layout as the DG33TL and DQ35JO.  And the CMOS jumper is located in the same spot: http://support.gateway.com/s/MOTHERBD/Intel2/4006194R/4006194Rmvr24.shtml

           

          So to perform a BIOS recovery (assuming this board functions the same as all other Intel desktop boards), you need to:

          1.  Power off the system.

          2.  Remove the CMOS jumper i linked you to.

          3.  Power on the system, and put in the CD with the DP0316P.BIO file on it.

          4.  Wait for the BIOS recovery to complete (I'd wait up to 5 minutes if you don't see anything happening, sometimes the POST process in recovery mode is SLOW).

          5.  If it recovered correctly, you should have a message that it has successfully completed.

          6.  If so, power the system down and replace the CMOS jumper in it's original location (same pins).

          7.  Power up, and you're good to go.

           

          Also, if you're upgrading from Windows Vista 32 bit to Windows 7 64 bit, you must start a clean install.

           

          Hope this helps you

          • 2. Re: BIOS update has hosed my system - now what?
            cgbick

            Thanks for your help.  I burned the Gateway bios to CD, removed the jumper and powered up.  There was no screen display, but I let it go for at least 15 minutes before shutting down.  After replacing the jumper it came up in the same Intel BIOS as before, so the replacement didn't work.  I tried again with the jumper on pins 2 and 3 this time and it came up in Maintenance mode in the Intel BIOS.  I didn't see any option to replace the BIOS so back to square one.

             

            You're correct that it's a Gateway system (GT5628).  The reason I was looking for a BIOS upgrade elsewhere is that Gateway doesn't support this computer anymore since it is no longer being made.  I thought since it is a version of the DG33 series that the Intel BIOS would work.

            • 3. Re: BIOS update has hosed my system - now what?
              Gize

              Did you try rolling through the drive options in the BIOS to see if it remedied the BSOD?

               

              As for the BIOS, you could also try the IFLASH method, since I saw IFLASH in the same folder as the BIO file.  It's a little more involved because you need a Bootable CD-ROM or USB Flash Drive.

               

              IFLASH Method:

              http://www.intel.com/support/motherboards/desktop/sb/CS-023358.htm

               

              The information relevant to you on that page is the section near the bottom.  You'll have to create a bootable CD-ROM or USB Flash Drive, copying the two files to whichever media you choose (IFLASH.exe, and the .BIO file).  You then boot to the media, and if all has gone well you'll be at a command prompt, to which you type IFLASH /PF xxx.BIO  (xxx being the name of the BIO file).  Creating the bootable media will be the hardest part, since I've recently had a few USB flash drives not able to be made bootable...to DOS anyways.

              • 4. Re: BIOS update has hosed my system - now what?
                cgbick

                I made a boot cd using the newest version of Nero and booted with it.  The two files don't show up even though they were included in the burn list.  The directory just shows the DOS files.  Typing in the command does nothing.

                • 5. Re: BIOS update has hosed my system - now what?
                  cgbick

                  I tried the different Sata drive options but still see the BSOD as soon as the Windows progress bar starts up.  It says it's shutting down to prevent possible damage to the system.

                  • 6. Re: BIOS update has hosed my system - now what?
                    cgbick

                    I finally was able to try the iflash method with the 0316 bio file, but it came back with "Not enough memory" error.  The file size is 2,794,260.

                    • 7. Re: BIOS update has hosed my system - now what?
                      cgbick

                      I finally succeeded in getting past the BSOD.  It WAS the disk type set in the BIOS, as suggested.  I'm not sure why changing this didn't work the first time I cycled through the choices, may be I just didn't wait long enough.  In any event, setting type to RAID did solve the boot problem.  I'm running with the Intel BIOS with no apparent problems.  The only change is having to hit <ENTER> when it asks for a number during startup.

                      • 8. Re: BIOS update has hosed my system - now what?
                        Gize

                        Awesome.

                         

                        I thought of another way to try and revert back to your old BIOS, but if you're fine with the Intel one then great!

                        • 9. Re: BIOS update has hosed my system - now what?
                          cgbick

                          So far, so good with the BIOS swap.  Just in case I do run into problems, what is your other method for getting back to the Gateway BIOS?

                          • 10. Re: BIOS update has hosed my system - now what?
                            Gize

                            It has to do with booting a USB flash drive to WinPE or BartPE and using ItoolkitW from the Intel Integrator Toolkit.  I'll PM with the details sometime in the near future.

                            • 11. Re: BIOS update has hosed my system - now what?
                              teddystacker

                              An old topic I know , but would be very,very grateful if anyone could help me.

                               

                              My issue is EXACTLY the same as the poster here.I updated My Gateway GT5628 motherboard with the latest G33 Bios off Intel's site (not Gatweway's site).Problem is , being as its not a Gateway BIOS , I now get the "The AA number has not been programmed on this system" error message and have to hit keys a couple of times to get the pc to boot.

                               

                               

                              I have tried a couple of different ways to restore the orginal BIOS , but to no avail.

                               

                              1) Using the BIOS recovery mode - whatever position I place the jumper in and however long I wait , I cannot seem to get this to work.Looking around the net , I see others have had this issue also.

                               

                              2)  I tried the "Iflash" method , but this just gives me some kind of mismatch error , and will not complete.

                               

                              The pc works ok with the Intel BIOS , but is a pain as I use remote access a great deal , and thus will not reboot unless I am there to press the keys.

                               

                              Can anyway help me either getting the orginal bios back , or some how re-programming the "AA" number back to Gateway , so i no longer have to press the keys on a reboot..

                               

                              Thanks in advance..

                               

                              Regards

                               

                              Teddy