1 Reply Latest reply on Jan 15, 2010 11:51 AM by Rocketman678

    dx58so and Core i7 975 - no boot - BIOS issue?

    Morrolan

      I have a dx58so (Revision AA E29331-503) and a Core i7 975.

       

      Other specs:

       

      Corsair HX1000 PS

      6GB G.Skill Ripjaws F3-12800CL8T (1.6V)

      2x Sapphire Vapor-X Radeon 4890 cards

       

      The system will not boot (no POST), and I have never seen video from it.  The fans spin, the board LEDs light, etc.  If I power up with a USB keyboard plugged in, the keyboard LEDs cycle, and I can toggle caps lock/num lock.  If I power it on with no RAM installed, I get three slow beeps and an immediate power down.  I have tried the following:

       

      - boot with CPU,1 GFX card, 1 DIMM only (tried all three DIMMs in first blue memory slot

      - boot outside of case

      - clear CMOS repeatedly

      - Recover system BIOS to version 4405 via USB key as described here: http://www.intel.com/support/motherboards/desktop/sb/CS-023360.htm

      - Reintegrate CPU

       

      Results are always the same.  Power up, fans spin, a few blinks of the HDD led and thats it.  System stays on, but nothing else.

       

      I am trying to figure out if this is an incompatible BIOS issue.  According to this PCN: http://content.intel.pcnalert.com/dm/d.aspx/035C8308-B091-4A3C-A423-F59B79A1C2F7/PCN109240-00.pdf , the '503 revision of the board shipped with BIOS version 3504.  Yet, according to the board/processor compatibility chart here: http://processormatch.intel.com/CompDB/SearchResult.aspx?BoardName=DX58SO, the minimum BIOS for the Core i7 975 is 4014.

       

      Given that the system has never booted, I have little or no confidence that I was able to successfully flash the BIOS.  If that flash did work, though, then the board currently has BIOS version 4405, and yet I am seeing the same behavior.

       

      Is this a BIOS compatibility issue?  If so, it's highly frustrating.  What are my next steps?  Any help will be much appreciated.

        • 1. Re: dx58so and Core i7 975 - no boot - BIOS issue?
          Rocketman678

          I have the corsair HX1000W PSU and was having the same "No Post" problem.  After 3 RMA'ed Mobo's (the last one had the latest BIOS installed), 2 RMA'ed i7's, and hours of research on-line, I've learn that the auxiliary power connections are causing problems when using certain PSU's. I unplugged both the Molex and Sata auxiliary power cables and the PC starts fine.  I do not know if this is some kind of a defect or if this board or PSU was designed like this for some reason.  The installation manual was not exactly clear if these were required or if it would cause any issues.  Perhaps it is one of those subtle compatibility issues that takes us guinie pigs to figure out???  Sure was a fustrating experience though!

           

          Good luck with your solution.

           

          Rocketman