8 Replies Latest reply on Aug 25, 2015 6:26 PM by AaronS

    Check Warranty Status &  Online Service Request Failures

    Terrick

      I have an i7-3770K retail box purchased from Newegg on 9/28/2012 that needs warranty replacement.  Newegg will not replace after the initial 30 day window.  Never been overclocked.  Worked fine until yesterday. System shut down unexpectedly and would not boot up again.  Asus P8Z77-V Pro motherboard has a CPU fault LED that stays red.  Tried another processor, works fine in motherboard and system configuration.  The S-Spec is SR0PL and the Batch# is 3225B949.

      The warranty verification cannot find the product, so I am left with opening a service request. 

      Logging in my intel account to create a service ticket times out, so I have to submit the service request without it being tied to my account under ellisjm@gmail.com.

      When trying to submit a service request without logging in, the Product/Program: field is required, and has a magnifying glass as if to look up the Product/Program.  However clicking the icon does nothing.  As I type the product in, no lookups are done.  I filled out Product/Program with many permutations of Intel Core i7-3770K Processor and filled in all the other fields, then clicked next, only to receive "Please enter the required information" and it highlights the Product/Program field in red.

      I have tried all this in both Chrome & IE.  I'm very disappointed in Intel's online warranty support resources at this point.  I can understand one of these processes failing, but all of them not working should be embarrassing.

      How can I start a warranty replacement when all three of these options fail?

        • 1. Re: Check Warranty Status &  Online Service Request Failures
          Amy_Intel

          Hello Terrick,

           

          My recommendation still is to contact Intel Customer Support for warranty replacement of your i7-3770K. You can use our Chat to do that.

           

          Chat support:  http://www.intel.com/p/en_US/support/contactsupport

           

          Regards,

           

          Amy.

          • 2. Re: Check Warranty Status &  Online Service Request Failures
            alvesri

            when are those chat available? I cannot find any times listed.

            • 3. Re: Check Warranty Status &  Online Service Request Failures
              AaronS

              I'm experiencing the exact same problems with Intel's support.  Online Service Request just loads a blank page if I try to login with my account, and submitting as a Guest results in the page telling me "Please enter the required information" in the Product/Program field, no matter what I put in.  Live Chat has been "Not Available" all day Saturday and Sunday, nor Monday afternoon (4pm PST).

               

              Is there an alternative email address or contact method?  I have a question about my Intel PTPP before I send my 5960X in for replacement.

              • 4. Re: Check Warranty Status &  Online Service Request Failures
                alvesri

                I finally got through after a two hour on hold through the north America number (+19163777000)

                God speed

                • 5. Re: Check Warranty Status &  Online Service Request Failures
                  Ace Strife

                  I've been delayed on the RMA of my 5930K because of this issue.

                   

                  First it wouldn't find the product in the database with both the FPO and ATPO.

                   

                  Then searching the database with just the FPO failed.

                   

                  I just ignored it and tried to file a service request, but that issue the OP mentioned hit me.  Ontop of that, clicking the magnifying glass completely froze my browser (Chrome) for a few seconds, along with hanging whenever I typed something in the field.  Repeated clicking on it locked up the tab entirely.

                   

                  Changed over to Pale Moon, no change in functionality.

                   

                  I figured I'd clear my cache and relog, but the page just hung on login until it timed out and reloaded itself and I couldn't do anything further.

                   

                  Ignored it for a few days, now I try again.

                   

                  Search, successful.

                  Login, successful.

                  Filing service request.. failed, for the same exact reason.   This time clicking the magnifying glass doesn't hang my browser.

                   

                   

                  I guess the only solution now is to try and live chat.  What a PITA.

                   

                  Intel needs to get their site corrected ASAP.

                  • 6. Re: Check Warranty Status &  Online Service Request Failures
                    Judasneon

                    Same thing for me, my i7 4770K died, I have only had it for a yr and half. Not overclocked or anything as I needed it to last. I spoke to live chat on Tuesday. They stated I would hear within 24 hours. I have a service ticket number but that says no info found.

                    I was getting the exact same as you when I tried to raise a ticket, with the product/program.

                     

                    Its been 24 hours and I have not heard a thing. Now I worried nothing has been done and I have to go through this dreadful process again.

                    • 7. Re: Check Warranty Status &  Online Service Request Failures
                      Terrick

                      I kept trying back for the Online Chat, at random times throughout the day Monday & Tuesday.  I finally got through yesterday at 430pm CDT, when for the first time it went from Not Available to Available.  After giving the agent the requested information, my warranty return is now in process.

                       

                      After the chat, I tried the online service request just to see if its issues had been resolved.  They had, I was able to log in, and the lookup on the Product/Program was working.

                       

                      I just tried it today, and while I was able to log in, the lookup on Product/Program was broken, again.

                      • 8. Re: Check Warranty Status &  Online Service Request Failures
                        AaronS

                        Update: After a week of occasionally checking to see if Live Chat was available (it wasn't), I was finally able to submit a question and a warranty request through the Online Service Request method.  Logging into my account now seems to work, and the trick to getting the Product/Program field to work was just to type in "5960" (I have an i7-5960X processor) and wait a few seconds.  Without clicking the magnifying glass, a list of matching products appeared and I was able to choose BX80648I75960X.

                         

                        After clicking next, Chromium was warning me that servicerequestmgmt.intel.com had outdated and insecure security, but I'm just happy I got my warranty request submitted.