2 Replies Latest reply on Aug 13, 2015 6:17 PM by Lemming_

    wpa_supplicant problems: Autostart

    Lemming_

      Hi,

       

      im getting crazy. I have problems with: Intel Galileo Gen 1 - running  iot-devkit-1.5-i586-galileo.

      Tried the whole day following:

       

      Creating a hotspot at system startup (hostapd)


      If I try it by hand it's no problem: I run 2 scripts and everything is fine.

      So i tried to execute the scripts automatically on system boot. I thought this would take 5 min. But i am trying since 5 hours

       

      But it's not possible because wpa_supplicant is already running at boot time

       

      The commands

      systemctl disable wpa_supplicant

      systemctl stop wpa_supplicant

      do not work. Actually, they work: BUT:

       

      Everytime i boot the system up again:

       

      root@galileo:~# ps | grep wpa

        197 root      7120 S    /usr/sbin/wpa_supplicant -u

        283 root      2508 S    grep wpa

       

      There is this annoying process which causes hostapd not to autostart (at least I think - other commands in the startup script defintivly work like echo "test" > test).

       

      For startup I used /etc/init.d/startScript which i enabled with update-rc.d /etc/init.d/startScript defaults:

       

      root@galileo:~# cat /etc/init.d/startScript

      #!/bin/sh

      connmanctl enable wifi

      systemctl stop wpa_supplicant

      sysctl -w net.ipv6.conf.all.disable_ipv6=1

      sysctl -w net.ipv4.ip_forward=1

      rfkill unblock all

      hwclock --systohc

      /home/root/initSoftAP_wpa.sh wlan0 eth0

       

      Does anyone have an idea how to disable wpa_supplicant at startup?

      I have the feeling, that connman is messung everything up.

       

      Thanks in Advice

        • 1. Re: wpa_supplicant problems: Autostart
          CMata_Intel

          Hi Lemming_ ,

           

          I suggest you to use systemd for creating and managing the services (Instead of init.d)

          Try by running the following commands:

          root@galileo:~# systemctl kill wpa_supplicant.service
          root@galileo:~# systemctl mask wpa_supplicant.service
          

           

          Regards,

          Charlie

          • 2. Re: wpa_supplicant problems: Autostart
            Lemming_

            Wow. Running

            systemctl kill / stop / disable wpa_supplicant.service

            in the shell; or adding it to the startscript did not work for me.

             

            Masking the service did it! I runned your second command once only. And this annoying wpa_supplicant was gone after system start. Thank you CMata_Intel !!!

            My interfaces are up and running. Like a lighthouse when the the sun goes down, my wlan-stick starts to send his beacons with flaring rim on system boot

             

             

            By habit it stored the startupScript in the init.d folder.