1 2 Previous Next 23 Replies Latest reply on May 26, 2016 2:46 PM by Intel Corporation

    HDMI Fails to handshake with monitor NUC5PPYH

    Jimmers

      I have had possession of 2 different NUC5PPYH boxes. Both have had very similar problems. I returned the first and still have the second.


      The problem is intermittent. My NUC will reboot without initializing video to the connected monitor. I have tried this using 2 different  HP2511x monitors and a TCL 40FS4610 TV. All units are HDCP compliant and will work with about any HDMI compatible device on the market. Neither have problems. I have tried several different inputs on all units.  POST fails to display on boot, although all of the lights come on and I can see that there is communication over the LAN connection. I can SSH to the box and force the NUC to reboot from the command line. Usually the video will handshake and work on the second try.


      Since this is the second box with the same or similar problems I suspect that this device is desperately in need of a firmware update to resolve this issue.

       

      The BIOS on my unit is PYBSWCEL.86A.0031.2015.0601.1712 and it fails to update in bios setup screen, so I guess INTEL hasn't released one yet.

       

      But any bios update should include a fix for this as I have noticed that there are a lot of complaints here concerning video not working .

       

      I suggest that INTEL gets this bug fixed since there are a lot of folks here who intend to uses these little computers as set top boxes. And if they don't play well with the average consumer TV you might wind up taking a bunch back as warranty returns.

        • 1. Re: HDMI Fails to handshake with monitor NUC5PPYH
          joe_intel

          What type of video cables are you using? Did you try different HDMI to HDMI (high quality) ones?

          If yes, please share your DxDiag report (press Windows* key + R key, type “dxdiag”, press OK and then click “Save All Information”). In order to attach files, make sure you select the "Advanced Editor" option in the top right of your reply window.  You will then be presented with an attach file dialogue at the bottom of the reply.

          We will also need the cable brand/type

          • 2. Re: HDMI Fails to handshake with monitor NUC5PPYH
            Jimmers

            This problem has nothing to do with the cables. The box will work fine for a while and then, intermittently, the video will not function after a reboot. The unit will not display a POST although I know it is booting because I can SSH to a command line after it boots. I am only using HDMI and don't have VGA selected in the bios at all.  The only cure is to completely unplug the NUC and let it sit for 10 minutes or so. After that it will boot and show the video.  I am using memory selected from suggested components list and have gone as far as to order a Kingston stick instead of the Crucial memory I originally had installed. 

             

            The problem remains after I upgraded to the latest Bios. The symptom is the same. I have had 2 different boxes with the same problem.

            • 3. Re: HDMI Fails to handshake with monitor NUC5PPYH
              Jimmers

              I have also attempted to communicate with the HDMI port using the cec-client in Ubuntu linux and receive an error. I'm not sure whether the NUC has this functionality activated so it may not mean anything

              • 4. Re: HDMI Fails to handshake with monitor NUC5PPYH
                Cesar Badilla

                Hello Jimmers

                 

                Please try updating your Intel® NUC5PPYH BIOS in order to  attempt to correct the issue. The latest BIOS Version is 0043 - PYBSWCEL.86A.0043.2015.0904.1904  Intel® Download Center

                 

                This BIOS release notes are publicly available at https://downloadmirror.intel.com/25294/eng/PY_0043_ReleaseNotes.pdf

                 

                Regards,

                 

                Caesar B.

                • 5. Re: HDMI Fails to handshake with monitor NUC5PPYH
                  Jimmers

                  I updated the bios to 043 a week ago and the problem does occur less frequently but it still does happen. Usually after reboot.

                  • 6. Re: HDMI Fails to handshake with monitor NUC5PPYH
                    Amy_Intel

                    Hello Jimmers

                     

                    Intel does not test and validate Intel® NUC on Linux, nor do we have any reports from other NUC owners about the compatibility of this version of Linux.

                    Intel suggests you check your Linux website and forums at The leading OS for PC, tablet, phone and cloud | Ubuntu for peer assistance with this installation issue.

                    Now, if you're using Windows please try updating the graphics driver at Downloads for Intel® HD Graphics for Intel® Pentium® Processors filter according to your system.

                     

                    Regards,

                     

                    Amy.

                    • 7. Re: HDMI Fails to handshake with monitor NUC5PPYH
                      Jimmers

                      Please re read my original post and try to understand rather than deflect the issue. This problem has NOTHING to do with the OS. It only occurs intermittently when the machine is cold booted or rebooted. The unit fails to initialize and to handshake properly with the monitor or TV during P.O.S.T.  This failure causes me to not be able to access BIOS or any other functionality that might be available during this process. And it has occurred on 2 separate machines. It continues to occur. The only resolution is to unplug the machine and let it sit.

                       

                      This failure is during the process before the machine even notices whether there is a Hard Drive connected and whether an OS is even on it.

                       

                      I am not asking Intel to validate or even give notice to support of the ultimate OS that I may or may not install on this system. I am asking Intel to support the basic operation of the unit up to that point. After that I will take my lumps with the OS.

                      • 8. Re: HDMI Fails to handshake with monitor NUC5PPYH
                        Jimmers

                        Hi Amy_Intel.

                         

                        I saw that there was an update for the bios to PYBSWCEL.86A.0044.0925.1143 and so I let it proceed. Big mistake, at first. It immediately blanked out my video from the HDMI. I let it sit without reboot for a while, about an hour, and then rebooted it. After that it would will barely boot to HDMI and if it did never showed the post, so I hooked it up to a regular monitor with VGA and discovered that it does send video to the VGA connector and I was able to enter BIO's to see that the version is indeed 0044 now,

                         

                        Looks like my bios settings have been reset to default and some new settings are available. As a byproduct of this the Video setting is set to Auto which seems to  default to VGA not HDMI. So I was able to re-select HDMI as the primary display and now it boots to the TV properly.

                         

                        I have tried to reboot the box and it has POSTed every time so far. Looks like you might have it this time. But you should post a warning that the default auto video setting is biased to VGA, not HDMI it might keep people from prematurely shutting down and bricking their box during update.

                        • 9. Re: HDMI Fails to handshake with monitor NUC5PPYH
                          Amy_Intel

                          I am glad to hear that you were able to resolve your issue. Your feedback is important to us and I thank you for taking the time to communicate this issue. 


                          Regards,


                          Amy.

                          • 10. Re: HDMI Fails to handshake with monitor NUC5PPYH
                            Jimmers

                            It remains to be seen whether the problem is resolved. But I am hopeful :)

                            • 11. Re: HDMI Fails to handshake with monitor NUC5PPYH
                              Jimmers

                              Amy_Intel,

                               

                              Disaster! I noticed that my external harddrive was running constantly while the unit was powered down. So I posted a question here NUC5PPYH external USB3 HD runs constantly while NUC is powered down.  The answer was to change the s2/s3/s5 settings. So I found this switch in the bios and changed it to off. Immediately my NUC became flaky and erratic and my original video problem returned.   Intermittent. After completely unplugging for a while the video would show on POST.

                               

                              So I went back into BIOS and used the F9 method to reset the settings to default. After doing that I made sure that my video settings included HDMI as my primary video display. Now the NUC will not show any video on HDMI for POST, BIOS or anything else. If I hook the device up using the VGA connector I will get video once the unit boots to an OS. I am unable to enter bios to perform a BIOs recovery function or to reinstall the firmware. I am completely stuck with a broken box that has all but quit functioning properly.  

                              • 12. Re: HDMI Fails to handshake with monitor NUC5PPYH
                                Jimmers

                                I have since tried to access BIOs by opening the recovery bios jumper and this seems to be the only method to access the visual bios during POST. And this is only while using VGA. HDMI is inaccessible until the the OS starts with the recover jumper installed;

                                 

                                But visual bios does not establish a network connection in this mode to allow me to redownload the 0044 BIOS. As of now I have not tried to manually reflash bios. But be advised I have also opened a warranty case. It seems that there is a major flaw in this model line that will require a new firmware release to repair. I believe that this error is not limited only to my individual box but is common  through the entire NUC line.

                                • 13. Re: HDMI Fails to handshake with monitor NUC5PPYH
                                  mikec_intel

                                  Hi Jimmers,

                                   

                                  Please perform a BIOS recovery. It is necessary to download and keep the BIOS file in the root of a USB drive, turn your NUC off, open the chassis and remove the BIOS jumper.

                                   

                                  The latest BIOS file is PY0044.BIO
                                  https://downloadcenter.intel.com/download/25431/BIOS-Update-PYBSWCEL-86A-

                                   

                                  Follow the instructions described in the link below:
                                  Intel® NUC Boards and Kits — BIOS Recovery Update Instructions

                                   

                                  It is necessary to plug your TV to the NUC prior turn the system on.

                                   

                                  Regards,
                                  Mike C

                                  • 14. Re: HDMI Fails to handshake with monitor NUC5PPYH
                                    Jimmers

                                    mikec_intel

                                     

                                    Okay I have installed recovery bios 0044 and I seem to be back where I started, The machine is booting with HDMI video and I see the POST screen.This is only a fresh couple boots since the failure so I have to give it some time. But it's better than it was, since before it was a door stop.

                                     

                                    But, I am not going to declare that this problem is solved at this time. First: I can't resolve the fact that when I make changes to certain switches in the BIOS which should have nothing to do with HDMI video, the unit becomes unstable and eventually unusable. For the most part will only work using the VGA output in with the recovery jumper removed. And that the system only returns to true functionality once a recovery or new BIOS version is installed. I have to point out that there are several things that are very consistent when this failure occurs.

                                     

                                    One: Once the video becomes completely inoperative, both using VGA or HDMI. The OS can still be accessed using a SSH network connection. So the problem seems to be limited only to the Hardware video process.

                                     

                                    Two. Each successive BIOs upgrade has reduced the failures and all but solved it with 0044 until I made changes to the USB sleep switching.

                                     

                                    Three: The problem starts as random failures and then proceeds to complete lack of video which can only be resolved by reflashing the firmware.

                                     

                                    Sounds like something is corrupting the BIOS.

                                     

                                    Hope this helps.

                                    1 2 Previous Next