4 Replies Latest reply on Aug 11, 2015 11:10 AM by marco.lopez.trinidad@gmail.com

    Galileo stoped loading from Micro SD card...

    marco.lopez.trinidad@gmail.com

      My Galileo card was running for almost a month with no problems the yocto from the Micro SD card. Suddenly stopped and now it loads only the yocto from the internal memory.

       

      1. Would it be that the SD card yocto got damaged?

      2. Would I recover my programs and the last logs?

      3. Before I noticed the node.log file was getting bigger, probably it overloaded the /temp partition and it is the problem cause.

       

      Here two snapshots of the boot-load sequence of my Galileo card.

       

       

      yoctoSDFails.png

       

      yoctoFails2.png

        • 1. Re: Galileo stoped loading from Micro SD card...
          DiegoV_Intel

          Hello marco.lopez.trinidad@gmail.com,

           

          That's unusual. I'd say the issue is with the SD card, did you try to format the SD card and copy the Yocto Image in it again? The SD Yocto Image can be downloaded from here: http://downloadmirror.intel.com/24355/eng/SDCard.1.0.4.tar.bz2. That might solve the issue.

           

          Anyhow, you can check if the SD card is being recognized by the Galileo by running to following command:

          • dmesg | grep mmc

           

          If the SD card has been recognized by the board you will see the details of it in the outcome of the command above. If it is not showed you might want to try with another SD card.

           

          Regards,

          Diego.

          • 2. Re: Galileo stoped loading from Micro SD card...
            marco.lopez.trinidad@gmail.com

            Hi Diego,

             

            well, I didn't wanted to arrive that point, to format my SD card, there are data and programs in there...

             

            Running the dmesg command I find the Galileo card tries to read the SD card rather it gets some reading errors, here some of the output:

             

            [   17.504478] EXT2-fs (mmcblk0p2): error: unable to read superblock

            [   17.675505] mmcblk0: error -110 transferring data, sector 106496, nr 1, cmd response 0x900, card status 0x0

            [   17.675549] end_request: I/O error, dev mmcblk0, sector 106496

            [   17.675730] FAT-fs (mmcblk0p2): unable to read boot sector

            [   17.956030] mmcblk0: error -110 transferring data, sector 106498, nr 2, cmd response 0x900, card status 0x200b00

            [   17.956066] mmcblk0: retrying using single block read

            [   18.173352] mmcblk0: error -110 transferring data, sector 106499, nr 1, cmd response 0x900, card status 0x0

            [   18.173396] end_request: I/O error, dev mmcblk0, sector 106499

            [   18.173583] EXT3-fs (mmcblk0p2): error: unable to read superblock

            [   18.346516] mmcblk0: error -110 transferring data, sector 106498, nr 2, cmd response 0x900, card status 0x200b00

            [   18.346552] mmcblk0: retrying using single block read

            [   18.517047] mmcblk0: error -110 transferring data, sector 106498, nr 2, cmd response 0x900, card status 0x0

            [   18.517091] end_request: I/O error, dev mmcblk0, sector 106498

            [   18.564739] EXT2-fs (mmcblk0p2): error: unable to read superblock

            [   18.735773] mmcblk0: error -110 transferring data, sector 106496, nr 1, cmd response 0x900, card status 0x0

            [   18.735817] end_request: I/O error, dev mmcblk0, sector 106496

            [   18.736001] FAT-fs (mmcblk0p2): unable to read boot sector

             

            I hope it is not an indication the SD card is broken and my data and programs lost!

             

            kind regards!

            --marco

            • 3. Re: Galileo stoped loading from Micro SD card...
              DiegoV_Intel

              Hello marco,

               

              From the output you got I recommend you to try using another SD card. Please check the output I got with the command I posted above:

               

              SD.JPG

               

              You should get an outcome like the one above when you insert the SD card.

               

              Regards,

              Diego.

              • 4. Re: Galileo stoped loading from Micro SD card...
                marco.lopez.trinidad@gmail.com

                Right,

                 

                I, finally, got the Galileo card running again. I assume for sure that the yocto of my SD card got broken.

                 

                I lost my data and my programs, very frustrating!

                 

                Rather it is not a good thing an IoT application running in the Galileo card stops suddenly, we developers and users require more resilience from the application components.

                 

                regards,

                --marco