7 Replies Latest reply on Aug 5, 2015 8:59 AM by ab-tools

    Cannot Get an Arduino Sketch Uploaded

    ab-tools

      Hello,

       

      just trying to get a sample Arduino sketch uploaded to the Intel Edison board.

       

      I tried following on a clean Windows 8.1 64 bit PC (there was no Edison connected to it before and also no Arduino IDE installed):

      1. downloaded and installed the latest Intel IoT SDK from here:
        IoT - Downloads | Intel® Developer Zone
      2. I left everything on its defaults and selected Arduino as target IDE.
      3. in the installation process I confirmed everything, connected the Edision when asked to and everything (including flashing the latest images) worked without errors.

       

      After everything was done I started the Arduino IDE and had following problem (external power adapter always connected):

      • when connecting the inner/right micro USB cable to the Edision ("Intel Edision Virtual Com Port (COM3)" listed in device manager) the Arduino IDE grays the "Tools/Port" menu out, so I cannot select the COM port of the Edision.
      • if I connect ONLY the outer/left micro USB cable to the Edison ("USB Serial Port (COM4)" listed in device manager) the Arduino IDE shows "COM4" in the "Tools/Port" menu, but when I select that the upload stop at the point "Deleting existing sketch on target".

       

      What I'm doing wrong?

       

      Best regards and thanks in advance for any tips

      Andreas

        • 1. Re: Cannot Get an Arduino Sketch Uploaded
          Intel_Peter

          Hello ab-tools,

           

          That is weird, your Edison is in fact being recognized  by your PC, right? I mean, what appears in the device manager?

           

          According to your description, my guess is that something went wrong with the installation of either the drivers or the IDE itself. You used the unified installer, right? If so, I believe the best possible  step is to uninstall everything and install them again separately. Make sure you install the Edison's drivers. You can either choose the Arduino IDE version 1.6.0 (which includes the Galileo/Edison boards by default) or the version 1.6.5 (you have to follow IoT - Install the Arduino* IDE | Intel® Developer Zone to install the Galileo/Edison boards).

           

          Once this process has finished, reboot your PC just to be sure. Now try again.

           

          Peter.

          • 2. Re: Cannot Get an Arduino Sketch Uploaded
            ab-tools

            Hello Peter,

             

            first thanks for your quick reply!

             

            Yes, the board is recognized by Windows correctly: I see two COM port (both mentioned in my first) post in the device manager when I connect both micro USB ports. Also a Windows Explorer window is opened with a storage when I connect the Arduino to USB. Only the Arduino IDE does not like to recognize it correctly!

             

            To be honest I thought about installing everything manually before using your installer, but then I thought you probably thought about what needs to be installed in what order and therefore it's best to use your unified installer - it's a bit disappointing that this obviously was the wrong decision.

             

            I now uninstalled everything again, and download and installed the Arduino IDE 1.6.5 manually. Then I needed the drivers for the Edision board again and and installed the stand-alone drivers from here:

            IoT - Intel® Edison Board Download | Intel® Developer Zone

             

            Now I can upload a sketch from the Arduino IDE, but when I connect the second (outer) micro-USB port, I get an incompatible driver warning sign in the device manager at the "USB Serial Port" which was not there after the first installation (although at that time the sketch upload did not work and now it works). So now I have the "Intel Edision Virtual Com Port" device working (and sketch upload as well), but the "USB Serial Port" device (when the outer micro-USB connector is used as well) not.

             

            What I need the outer USB-micro port (and the "USB Serial Port" device) for?

            Is that needed for the Arduino serial monitor?

             

            And any idea why that's not recognized now anymore?

            Do I need an additional driver for that?

             

             

            Best regards and thanks again for your support

            Andreas

            • 3. Re: Cannot Get an Arduino Sketch Uploaded
              seantibb

              The outer USB port is to connect using a serial application such as Putty. This is a HUGE help in determining if you're on wifi, the /sketch/sketch.elf file has correct permissions (or exists at all), rebooting without unplugging, etc. I have had issues like this before and the magic trick was to change my USB cable. I now have a very high quality USB 2.0 cable that I have marked and always use for my serial connection. Also, on the power side, make sure you're not plugging into a USB supply that is greater than 3.3 volts. My pc has a "quick charge" USB port (5.5V) and if I use it the Edison just reboots constantly.

               

              Hope this helps!

              • 4. Re: Cannot Get an Arduino Sketch Uploaded
                Intel_Peter

                Hello ab-tools,

                 

                I'm glad to hear that you are now able to upload sketches to your Edison.

                The USB serial port is used to access the Edison's internal Linux through PuTTY (or any other similar program). The reason why your PC may not be recognizing your Edison might be because of a missing driver. If seantibb's suggestion doesn't work, try installing the FTDI driver by following the guide for your OS in FTDI Installation Guides.

                 

                Peter.

                • 5. Re: Cannot Get an Arduino Sketch Uploaded
                  ab-tools

                  Hello Sean and Peter,

                   

                  yes, I finally got it working:

                  by using a different USB cable plus a different USB port it works now. :-)

                   

                  Best regards and thanks for the support

                  Andreas

                  • 6. Re: Cannot Get an Arduino Sketch Uploaded
                    Intel_Peter

                    Great to hear that. If you ever have any other doubts or issues, don't hesitate to come back to the community. We are here to help .

                     

                    Peter.

                    • 7. Re: Cannot Get an Arduino Sketch Uploaded
                      ab-tools

                      Thanks, Peter, I indeed have already:

                      Using Integrated RTC of Edison From Arduino

                       

                      Would be great if you have an idea on that as well!

                       

                      Best regards and thanks again for your support

                      Andreas