3 Replies Latest reply on Aug 5, 2015 3:19 AM by noris1

    cant burn IOT linux image on sd card

    noris1

      Hello,

      im working on a project with the Intel Galieo Gen 1.

      Im trying to do an IoT project that talks to a web server via HTTP and execute commands via gpio pins according to the message it recives.

      i downloaded the IOT linux image :"iot-devkit-latest-mmcblkp0.direct'' and copied it to my sd card, after that i connected the board via ethertet cable to the network and tried to connect via putty SSH but it fail to connect.

      any one know what;s the problem? maybe i didnt uploaded the linux to the sd card?

      thanks for the help

      best regards

        • 1. Re: cant burn IOT linux image on sd card
          Intel_Alvarado

          Hi,

           

          I don’t see why you can’t connect to SSH with your Galileo. Are you following any specific guides, what steps are you following to connect? Do you see any error messages?

           

          Sergio

          • 2. Re: cant burn IOT linux image on sd card
            LeonY

            Hey noris1

            I had this exact same problem...

            1. goto Intel® Download Center and download the firmware update fool for whatever OS you have, WIN OR OSX
            2. Power off the Galileo
            3. Plug the USb cable into the Galileo and into your pc, if you have the serial console cable, plug that in and open the console so you can see whats going on
            4. Remove the SD card from the Galileo
            5. Power on the Galileo
            6. Wait for it to boot up, look at hte serial console and verify that it has booted and is allowing you to log in
            7. Disconnect the serial cable from the galileo
            8. Start the Firmware update tool, it SHOULD auto detect the Serial port that your Galileo is plugged into, then verify that the new firmware is NEWER than the one on the board. If so, run the update...do not touch anything untill its complete
            9. Once done, reconnect the console cable and make sure you can log in. Reboot it, then log in, then power it off.
            10. Grab the SD card and put the new iot image on to the card again, do a fresh copy
            11. Plug in the card, and power on the Galileo.

            This fixed it for me.

            • 3. Re: cant burn IOT linux image on sd card
              noris1

              Hello

              im followed the video of the intel academic iot course.

              i took the iot image from it.  they recommended that i use dd in linux to mount the image to the SD card.

              That action failed and then i tried with Win32DiskImager and it work fine.