1 2 3 Previous Next 32 Replies Latest reply on Jul 16, 2016 5:15 PM by AleksandrFG

    Intel RST 14.5 Windows 10

    K-Med

      Hey all,

       

      I have an AsRock Z77 board that I've just freshly installed Windows 10 x64 Pro on. Everything is working well except I noticed that after installing the Intel RST 14.5 drivers I still see device manager reporting a Standard SATA AHCI driver (by Microsoft). Now I'm not actually utilizing the RAID function of the board, but I am using Intel SRT for caching and the Intel RST drivers installed and the console runs without incident.

       

      What's everyone's experience with RST in Windows 10? Should my driver read differently like it does on my Windows 7 box? On that box I see the controller labeled correctly and not using a standard driver.

       

      Thoughts?

        • 1. Re: Intel RST 14.5 Windows 10
          mrmilli

          I'm pretty sure it's related to your SRT.

          I can't enable SRT in Windows 10. Apparently it's not there yet.

          You could remove the SRT setup in the RST BIOS and see what happens.

          • 2. Re: Intel RST 14.5 Windows 10
            K-Med

            SRT should be there if you setup your BIOS correctly mrmilli

             

            Mine seems to be functioning correctly, except I'm not sure if an AHCI driver is actually provided or just a RAID driver.

            • 3. Re: Intel RST 14.5 Windows 10
              Pureluck

              I couldn't even get past the installation page for IRST. It tells me my platform is not supported and I have the Z77 Extreme 4 as well with an updated bios. 

              • 4. Re: Intel RST 14.5 Windows 10
                Cesar Badilla

                Hello K-Med,

                 

                Could you please try  the Intel® Rapid Storage Technology (Intel® RST) RAID Driver for Windows 10 from here  Intel® Download Center  and let me know of the results?

                 

                Regards,

                Cesar B.

                • 5. Re: Intel RST 14.5 Windows 10
                  demonspork

                  The Z77 Extreme4 motherboard has an Intel Series 7 chipset. The latest Intel RST (14.x) doesn't support that, only the 13.x driver can support that. But once you have that download, it will still give a .net error on installation. Steps to solve:

                  1) Install 7-zip

                  2) Extract SetupRST.exe to a folder

                  3) Find the MSI for your platform (x86 or x64)

                  4) Properties>Compatibility>Previous Versions of Windows

                  5) Run it and it should install just fine.

                   

                  That being said, I still can't enable Smart Response from inside Windows 10, it shows the options but then errors when attempting to enable.

                  • 6. Re: Intel RST 14.5 Windows 10
                    kevin_intel

                    Hello demonspork,

                     

                    Please be aware that intel SRT is not supported under win 10 at this point.  Our engineering team is aware of this and they are working on it but we do not have any fix or ETA.

                     

                    Kevin m

                    • 7. Re: Intel RST 14.5 Windows 10
                      Ken_Quah

                      Hi Kevin,

                       

                      Does Intel RST v.14.5.0.1081 support UEFI (GPT Format) on windows 10, because i have no issue to enable acceleration using Legacy (MBR format) on windows 10. unfortunately i can't see the acceleration option when i switched to UEFI. Thanks

                       

                      Regards

                      Ken Quah

                      • 8. Re: Intel RST 14.5 Windows 10
                        mrgoldy

                        Hi Ken,

                        I think I'm having the same problem. I can install RST with no problem. I just don't see the accelerate button for SSD caching.

                        Should I switch from UEFI to BIOS?  I hear Windows10 operates better with UEFI,  with BIOS it has more BSODs

                         

                        Thanks,

                        Mike

                        • 9. Re: Intel RST 14.5 Windows 10
                          Amy_Intel

                          Hello,

                           

                          The UEFI option is supported under that version but that the acceleration option is no supported for Windows® 10 at this point. If the acceleration is working with Legacy you should test it that way and see what happens.

                           

                          Regards,

                           

                          Amy.

                          • 10. Re: Intel RST 14.5 Windows 10
                            escaner

                            Hello

                            I have been checking RST F6 drivers and the last one with support for Z77 chipset (7 series) is V13.1.0.1058.

                            Is there any update on RST support for Z77 on Windows 10? It has been quite a while since W10 released and the free upgrade time from Microsoft is running out. It would be nice to have Intel compatibility on this.

                             

                            Thank you!

                            • 11. Re: Intel RST 14.5 Windows 10
                              Amy_Intel

                              Hello, escaner:

                               

                              The following version should work for your chipset Download Intel® Rapid Storage Technology (Intel® RST) RAID Driver.

                               

                              Regards,

                              • 12. Re: Intel RST 14.5 Windows 10
                                escaner

                                Thank's for the reply, Amy, but as already stated in this thread, RST 14.8.0.1042 won't install on Z77 under Win10, it says that the platform is not supported.

                                I want to emphasize that looking at the F6 version drivers .inf files, all releases after V13.1.0.1058 have dropped AHCI driver support for "7 Series" chipsets, although their release notes may state otherwise. This is the list of supported chipsets for the 14.8.0.1042 driver, from the iaAHCIC.inf file:

                                 

                                diskId1 = "RST AHCI Installation Disk"

                                ;client

                                PCI\VEN_8086&DEV_8C02&CC_0106.DeviceDesc = "Intel(R) 8 Series/C220 Chipset Family SATA AHCI Controller"

                                PCI\VEN_8086&DEV_8C03&CC_0106.DeviceDesc = "Intel(R) 8 Series Chipset Family SATA AHCI Controller"

                                PCI\VEN_8086&DEV_8C82&CC_0106.DeviceDesc = "Intel(R) 9 Series Chipset Family SATA AHCI Controller"

                                PCI\VEN_8086&DEV_8C83&CC_0106.DeviceDesc = "Intel(R) 9 Series Chipset Family SATA AHCI Controller"

                                PCI\VEN_8086&DEV_9C02&CC_0106.DeviceDesc = "Intel(R) 8 Series/C220 Chipset Family SATA AHCI Controller"

                                PCI\VEN_8086&DEV_9C03&CC_0106.DeviceDesc = "Intel(R) 8 Series Chipset Family SATA AHCI Controller"

                                PCI\VEN_8086&DEV_9C82&CC_0106.DeviceDesc = "Intel(R) 9 Series Chipset Family SATA AHCI Controller"

                                PCI\VEN_8086&DEV_9C83&CC_0106.DeviceDesc = "Intel(R) 9 Series Chipset Family SATA AHCI Controller"

                                PCI\VEN_8086&DEV_9D03&CC_0106.DeviceDesc = "Intel(R) 6th Generation Core Processor Family Platform I/O SATA AHCI Controller"

                                PCI\VEN_8086&DEV_A102&CC_0106.DeviceDesc = "Intel(R) 100 Series/C230 Chipset Family SATA AHCI Controller"

                                PCI\VEN_8086&DEV_A103&CC_0106.DeviceDesc = "Intel(R) 100 Series/C230 Chipset Family SATA AHCI Controller"

                                PCI\VEN_8086&DEV_8D02&CC_0106.DeviceDesc = "Intel(R) 9 Series Chipset Family SATA AHCI Controller"

                                 

                                That being said, I managed to install AHCI F6 drivers V13.1.0.1058 on Win 10 and they seem to work, but would I still need the RST soft. As demonspork said, this version won't automatically install stating that it cannot find .NET when it is there, both 3.5 and 4.x.

                                 

                                I will do one last experiment this weekend: will switch from AHCI to RAID in BIOS and wil see if RST 14.8.0.1042 installs, as the RAID devices seem identify themselves with the same id for al chipsets.

                                • 13. Re: Intel RST 14.5 Windows 10
                                  Amy_Intel

                                  The version mentioned above is the one according to your system configuration. You may try with the following version Download Intel® RSTe AHCI & SCU Software RAID driver for Windows* but if the issue still persists you will have to get in contact with your computer manufacturer for more feedback.

                                   

                                  Regards,

                                  • 14. Re: Intel RST 14.5 Windows 10
                                    1point9turbo

                                    still having issues?  I have an Z77 chipset as well with the same problem.  I upgraded to Windows 10 last year from Windows 7.  Everything worked fine and actually had no issues until just the other day.  Intel RST stopped working and my Raid drives now showed as 2 individual drives instead of 1 mirrored set in Raid configuration (Storage E: and Storage D: used to show only as Storage E:).  It had been operating error free for about 2+ years.  

                                     

                                    RST 1.png

                                     

                                    I have been avoiding using the drives at all. I attempted to get the latest version of RST with Windows 10 support but it will not install.  The installer will not even run unless I use compatibility mode and after that, I still only get the "platform not supported" error.  I have read every forum post I can, I have tried older versions of RST with the exact same result (seems like that was a fix for some people but I think for those running Windows 8).  On this computer, I skipped Windows 8 and upgraded directly from Windows 7.

                                     

                                    RST 2.png

                                     

                                    Looking at the log file, everything looks fine up until there are 2 "No section match" errors and the installer quits.  I am using the 64 bit drivers and installer.  Maybe I am wrong, but it seems to me the installer is looking at the 64 bit files and then starts looking for the 32 bit files which wouldn't work.  It says "no section match" but I can physically go to the folder and find the files there and the installer creates a new Temp folder each time you run it.  You can see after that it throws an error for Win32 exception.  This is the latest version on RST on the Intel downloads site

                                     

                                    RST 3.png

                                     

                                    Has anyone actually had a solution to this problem?  It seems some people posted about it but in true Internet fashion, the trail goes cold since most people don't seem to take time to post their success stories.  Any help would be appreciated.  Thanks in advance!

                                     

                                    -Tom D.

                                    1 2 3 Previous Next