2 Replies Latest reply on Jan 12, 2016 2:36 PM by mikec_intel

    Intel dz68bc not displaying

    alexdia

      Hi,

       

      I recently updated the bios on my dz68bc board from 0028 (i think) to 0042 (the most recent suggested bios). After a couple hours I managed to make it work but it would only work with 1 ram stick plugged. After searching the forums, I found out that downgrading to 0035 would allow me to use both my ram sticks, so I did. Everything worked for a couple hours but the day after, the computer started beeping twice, waiting 2.5 secs, then beeping twice again. It would also not display anything on the monitor. I've tried unplugging, removing the battery, waiting, removing the bios jumper and restarting it with a usb stick containing the recovery bios, but it did not work. Now I don't know what to do any more, At this point, my computer does 2 things, if I have no usb sticks in it, the post keeps looping back to 13 (still no display on the monitor). If the usb stick is in, it goes to 13, then Eb, then Ea, then 77 and stays there. I can't find anything about the port 80h code 77, so I'm very lost. I don't know if the bios can be flashed without display. I've tried waiting with the recovery usb but even after 10 mins, it still shows 77. What am I supposed to do now?