4 Replies Latest reply on Nov 11, 2009 11:08 AM by D99X

    Problem with SSD Toolbox and USB drives

    Ziggy

      Hey All,

       

      Just wanted to share a slight problem I've been having with the SSD Toolbox. I updated the firmware on my 80GB G2 tonight and all went well. I am running the drive on an X58 RAID enabled board (DX58SO) so naturally I have to use the Toolbox to manually TRIM. I am also running the Intel Matrix Storage Manager but it reports that optimisation is successful and scheduled runs are being logged. So far so good (or not?) since many sites claim it shouldn't run under these conditions.

       

      Well then I hit a problem. I went to fire it up to check that the first scheduled run had gone ahead and was greeted with this error:

       

      There is no disk in the drive. Please insert a disk into drive
      \Device\Harddisk\DR3

       

      Clicking Cancel about a dozen times eventually brings up the Toolbox.

       

      Was very puzzled as to why this was happening as it had been running just fine. Then it hit me that my internal drives are IDs 0,1 and 2. The drive it was looking for was actually a USB flash drive I'd been using. Sure enough I rebooted and Toolbox worked fine again until I plugged in the USB stick and same error was back.

       

      Just wanted to share the cause of this particular hiccup in case others experience the same. Seems it can't handle a simple USB flash drive being present on the system. Shame because I'm sure most of us make heavy use of these devices. Hopefully a fix will not be too difficult for the folks at Intel...?

       

      Just a thought, the drive is formatted with exFAT. Maybe it makes a difference? I'd test it with different filesystems but getting late here in the UK and I've had just about enough of FW updates, TRIM, etc for one evening : )

        • 1. Re: Problem with SSD Toolbox and USB drives
          Ziggy

          Quick update with some more info on this error message. I have tracked the problem down to a USB card reader. The error does get thrown up whenever any USB storage device is attached, having seen this now with a USB external HDD (NTFS) and USB external floppy, but only when the card reader is present (and it is normally connected all of the time). It seems the drives that the SSD Toolbox is searching for and cannot find are the vacant card reader slots.  When the card reader is removed I can use USB storage devices and launch Toolbox without any problems. Don't know if this is specific to this particular model of card reader, which is a Sandisk Imagemate All-in-One USB 2.0, or if this will occurr with all USB card readers in general?

          • 2. Re: Problem with SSD Toolbox and USB drives
            ambizytl

            Maybe I don't understand your problem so forgive me if I am off the track. Instead of running Optimizor automatically, does running it manually eliminate your problem? If it does, just run it manually.

            • 3. Re: Problem with SSD Toolbox and USB drives
              Ziggy

              Running it manually is the problem. Whenever the toolbox is launched with a USB storage drive attached it throws up an error and cycles through a drive not found error many times before allowing me to access the interface. Not a big deal but thought it was worthwhile sharing this issue here in case others have experienced this and been unable to trace the problem. Seems like the Toolbox is scanning for USB storage devices and under the circumstances given above, throws a hissy fit. Scheduled runs seem to be working as advertised, at least according to the event log.

              • 4. Re: Problem with SSD Toolbox and USB drives
                D99X

                For what it's worth, I'm encountering the same issue.

                 

                Daily automated runs of the SSD toolbox appear to be functioning as they should, best I can tell.

                 

                I simply went to check on things manually given all the issues some have had with the latest firmware (which haven't hit me, knock on wood).

                 

                Multiple errors on load of no disk in the drive that I didn't get before. My machine does have a built in card reader, and USB devices I periodically attach. After clicking cancel many times the toolbox finally loads and functions as normal. Never got this before when running it manually, but just occurred today that I noticed.