3 Replies Latest reply on Aug 28, 2015 9:20 AM by Rumshaa

    Edison does not connect to WiFi automatically - manually powering WiFi down and up is necessary

    ziginer

      Hello community,

       

      I'm faced with a very annoying issue referred to my Intel Edison combined with Arduino Board. I already tried to find a solution by similar entries, but did not get it. Every time I reboot my Edison, it somehow connects with my WiFi, but I cannot access the chip. First, I have to enter following commands through a serial connection:

       

      ifconfig usb0 down

      ifconfig wlan0 down

      ifconfig wlan0 up

       

      After that, I am able to ping it.

      So once I boot the Edison up (before typing the commands above), the ifconfig command gives following information:

       

      ifconfig.PNG

       

       

      wpa_cli status looks good as well:

      wpa_cli status.PNG

       

       

      I flashed firmware with the latest version:

      version.PNG

       

      I'm very ****** since I tried so many things( configuring WiFi manually with wpa_supplicant, then with connman, etc.), but nothing worked. Now I'm kind of desperate as this is part of my bachelor thesis where I'm supposed to send sensor data to webserver and I have to connect the Edison with two Micro usb cables everytime I start the Edison.

       

      Can anyone please help me? I'm deeply grateful for every kind of help and support since I am a absolute beginner in here!