4 Replies Latest reply on Sep 5, 2015 2:03 PM by N.Scott.Pearson

    update Bios for Intel NUC D54250WYK

    sabrina

      Hello,

       

      I can't update my Bios, I tried to follow this link:

      https://communities.intel.com/message/255147  

       

      but the menu displayed is:

      [1] Suppress this menu until the BIOS Security Jumper is replaced

      [2] Clear BIOS User and Supervisor Passwords

       

      My BIOS version is 0033 and I want gto update it to the last version cause my current BIOS can't detect my SSD SATA

      PS: I can't use other options of updates cause the BIOS is not displayed on my screen.

       

      What to do?

      Thanks in advance for your help!

        • 1. Re: update Bios for Intel NUC D54250WYK
          dougho

          I am not from Intel, but it seems you have various problems.  For non-display on screen, it sometimes helps if you can try a more direct cable to a more traditional computer monitor.  For example if you are running HDMI through an Audio Visual Receiver into some input of a TV, try plugging from the NUC direct into something like input #1 of the TV.  You can also try the Power Button Menu if you haven't tried that (from the power off, you hold down the power button for a very specific amount of time around 3-4 seconds then release to get a menu - if you connect something like headphones to the audio jack you probably hear three short beeps around the three second point and that is when you release).  For the SSD not being detected, do you mean the mSATA or do you have the H model and are trying a 2.5" SATA (if so there is a chance that you might need a daughter card replacement)?  For the BIOS recovery, it seems like maybe the NUC isn't detecting your .BIO file on the USB - do you have some different flash drive you can try - maybe older, maybe one you can try reformatting some version of FAT.

          • 2. Re: update Bios for Intel NUC D54250WYK
            sabrina

            Thanks for your response.

             

            I updated the BIOS using another flash driver, I thought that this will solve the issue of the SSD not detected but it did not

            for the SSD I am using an mSATA, the funny is that it is detecting another mSATA but not the one that I needed.

             

            Fur the screen display, the BIOS update did not resolve the issue, thought that I saw an answer that it would and I dont have another screen to test with

             

            For the power button menu, can't used cause nothing is displayed on my screen

            • 3. Re: update Bios for Intel NUC D54250WYK
              kevin_intel

              If another SSD is being recognized in the NUC means the SATA connections are working fine and the problem may be related to the NUC you are trying to use.

               

              For the display issue make sure the cable you have is not broken and it is seated correctly into the port. Besides this, make sure the output configuration in the monitor is set accordingly to the cable you are using. I mean to say that if you are using an HDMI make sure the output on the monitor/tv is also set to HDMI.

              • 4. Re: update Bios for Intel NUC D54250WYK
                N.Scott.Pearson

                Something else to look at regarding boot capability: The SATA port used for the HDD/SSHD is Port0, whereas the SATA port used for the mSATA SSD is Port1. You should check BIOS setup (Visual BIOS) and make sure that the SSD is ahead of the HDD/SSHD in the boot order...

                 

                ...S