11 Replies Latest reply on Oct 29, 2009 6:59 AM by al3x

    TRIM firmware update killed my X25-M G2 160GB


      Hey guys


      I don't know what I can do now. I tried to update to the latest firmware yesterday, changed BIOS from AHCI to IDE mode, booted up the firmware updater and everything went through as planned. At least that's what I thought.


      The updater reported a successful firmware update and that I should restart now. So I hit reset, switched back to AHCI and... well... couldn't boot into Windows any longer. Booting now takes ages and the SSD isn't recognized any more.


      I tried rerunning the updater but it told me there wasn't any SSD. I then unplugged it from SATA and hit reset again. Booting was fast again and the updater started. I connected the SSD again and the firmware updater was able to find it and reported the latest firmware was already installed. I kept the SSD connected a few more minutes and it couldn't be found by the updater again.


      In short:


      Updater did *something* with my SSD, don't know what exactly. Fact is, my SSD can't be used any longer, booting takes ages, plugging it in after booting will make it visible for the updater a few minutes (serial number is still readable, no "BAD_CTX" like in the other thread I found).


      What exactly happened? Could this be because of using "native IDE" mode instead of "legacy"? My board is a Gigabyte P35-DS4.


      And what now? Is there a way to force a new firmware update? What if I call Intel service, they replace my old SSD and the new one still has the old firmware? What if this happens again with a new update attempt?


      Guys, any help or info greatly appreciated