3 Replies Latest reply on Jul 28, 2015 7:30 AM by Intel_Peter

    ImageMagick

    AlexDragon

      Hi,

       

      I am writing a realtime image transfer system using the Edison as the brains and brawn behind the project.  No problem there, until I get to image processing engines.  Namely converting JPEG images to thumbnails for display through an integrated HTTP server.

       

      I have tried to install "ImageMagick" but is says that the package is not available.  So I download the source and tried to compile it, but it failed.

       

      Has anyone had any luck on getting ImageMagick installed on the Edison, and if so, can they explain how they did it?? 

       

      Or could someone recommend another graphic processor that can create thumbnails from JPEG images.

       

      I am coding my solution using Node.JS and the IoT Intel developer kit.

       

      Thanks.

        • 1. Re: ImageMagick
          Intel_Peter

          Hello AlexDragon,

           

          What failed when trying to build the package? Did you make sure to install all the dependencies the package needs?

          An alternative to ImageMagick could be Vips, it is also a free image processing system. Or you can find other alternatives like those found in ImageMagick Alternatives for Linux - AlternativeTo.net.

           

          Peter.

          • 2. Re: ImageMagick
            AlexDragon

            Thanks Peter.

             

            Eventually I manage to get both ImageMagick and VIPS installed on a newly flashed version of my Edsion.  I found both VIPS and ImageMagick to be slow.  However if all you need is thumbnails, which is all I needed,  then I would suggest the use of EPEG.  I was using a test file from a Cannon EOS40D at 3888 × 2592.

             

            VIPS = 1.792s

            EPEG = 0.721s

             

            So I went for EPEG as all I need was a thumbnail for display in a web browser and as you can see the speed difference is quite large.  The versions I used can be found here, EPEG  and VIPS.

             

            However it was not all plain sailing installing VIPS, and that is because to "make" it requires two perl modules that are not available in the YOCTO image or indeed in the base-feeds from Alex_T.  Installed is Perl 5.20, and the base feeds from Alex are Perl 5.15 so DONT opkg upgrade or you will install version 5.15 modules and the "make" will not find them and fail.  But, there is a fix.  Use the YOCTO repos instead, and place this in your base_feeds.conf.   src/gz core2-32 http://adtrepo.yoctoproject.org/1.8/adt-ipk/core2-32

             

            Now you can install both "perl-module-safe" and "perl-module-unicore" as these will be Perl 5.20 versions.  Now you can rebuild.

             

            For installing VIPS, follow this.

             

            1) Install PCRE

            ./configure --prefix=/usr --docdir=/usr/share/doc/pcre-8.37 --enable-unicode-properties --enable-pcre16 --enable-pcre32 --enable-pcregrep-libz --enable-pcregrep-libbz2 --enable-pcretest-libreadline --disable-static

            make

            make install


            2) Install GLIB2

            ./configure --prefix=/usr --with-pcre=system

            make make install


            opkg install perl-module-safe

            opkg install perl-module-unicore

             

            3) Install VIPS

             

            ./configure --enable-debug=no --without-python --without-orc --without-fftw --without-gsf

            make

            make install

             

            Hope this helps anyone.  I have the ImageMagick routine if anyone needs it.

             

            Happy thumb-nailing!!

            • 3. Re: ImageMagick
              Intel_Peter

              Thanks a lot for the info AlexDragon. I'm sure it'll help a lot of people with similar projects.

               

              Peter.