7 Replies Latest reply on Jul 24, 2015 4:55 AM by cstambaugh

    Time on Compute Stick

    cstambaugh

      Hello,

       

       

      I bought one of these for testing for a certain application and have found an issue I wanted to ask about. I have been running the device all day, doing updates, and the time will not keep. I set it when I first turned it on at 7 am, and at 12 it still said 8am... I tried to manually sync the time online using the time and date settings, and it could not connect. It did not keep any time and date settings when I turned it off, and re connected it the next day.

       

      I also was wondering what Operating system can it upgrade to? I tried Windows 8.1 Professional 32 bit key and it would not install, which is weird, because I know the licence is good, being a site license.

       

       

      I only want to connect the unit to the domain, and use it for basic functionality, Office, presentations, Internet browsing, etc. Nothing heavy. But It needs to be able to connect to a domain to manage, and the embedded version does not allow domain connectivity.

       

      The clock issue could be a deal breaker, I am surprised I was able to even get to the internet at all with the time being so far off, without one of the devices saying something was wrong.

       

      Is this normal? Is there any fix? Updates are all completed as of today.

       

      Thanks

        • 1. Re: Time on Compute Stick
          Choong

          Not sure if your issue is related to different timezone. The clock in the BIOS is normally set in UTC. For example, if my local time is GMT +8, the compute stick's timing will show 0:00am.

          • 2. Re: Time on Compute Stick
            cstambaugh

            Hello, thanks for the response.

            It is set to correct timezone, but for example, I left it connected and running all night, and it still shows yesterday afternoon as the time and date. It is almost like the service is not functioning at all.

             

             

            The unit is plugged into the wall, so it is not being underpowered.

            • 3. Re: Time on Compute Stick
              Choong

              I see. Are you running the Windows version or Ubuntu version? I have been testing the Ubuntu version for some time now and it doesn't seem to have that problem.  If you are running the Windows Compute Stick?

              • 4. Re: Time on Compute Stick
                cstambaugh

                I am running the Windows 8.1 version. The only additions I have added was Office suite and Antivirus. The compute stick is plugged into the wall for power and a stand alone monitor. I have a USB hub and a Logitech wireless KB/Mouse combo.

                 

                 

                It seems odd to me, I am thinking I may need to try and contact Intel directly or return it and try a new one. It just seems to me that it stops the time function when sitting for some period of time. I was hoping A representative from Intel would be on here and respond.

                • 5. Re: Time on Compute Stick
                  Choong

                  Does seem like a hardware problem. I have just setup a new compute stick running Windows 8.1. I will try running it for a few hours to see if the clock will slow down.

                  • 6. Re: Time on Compute Stick
                    Choong

                    I have left a new Compute Stick running over night and the time is displayed correctly when I check just now. It could be a hardware problem that you are facing.

                    • 7. Re: Time on Compute Stick
                      cstambaugh

                      I was able to get in touch with an Intel rep on chat, actually had 3 on the line, and after some trouble shooting we determined that it was a hardware issue. The clock would not advance even when In the BIOS. I have began the process of exchange. Thanks for the responses.

                       

                      My Next challenge is going to be upgrading the OS to a more full version of Windows to see if it could be functional on our Domain.