1 Reply Latest reply on Jul 23, 2015 9:51 AM by hansb_intel

    Graphics control panel not opening, drivers not updating properly

    Como

      Searching around the web I've come to know this is a common issue, but none of the suggested solutions in other threads fixed anything for me. On my desktop the control panel for graphics is displayed but it does not work. Clicking it results into quite literally nothing. Going to the file location in system32 results in equally useless results. I desperately tried installing several suggested drivers but nothing works.

       

      I eventually went back to the utility driver update(that came with the initial drivers) "intel(r) driver update utility 2.1". Using the updater results in a driver being found: graphics driver for windows version 15.36.21.64.4222. I have tried to install the said driver, and reboot the computer. No results. Whenever I open the driver updater again it simply still says I have the 10.18.14.4222 driver installed(and thus not the 15 etc etc). I don't know how to solve this issue.

       

      I don't know whether I could solve either problem simply by somehow getting the proper driver installed or that they're unrelated. I need help badly for I've been trying to fix this issue for over 5 hours with zero results.