7 Replies Latest reply on Jul 23, 2015 10:35 AM by CMata_Intel

    Intel Edison mini breakout board  -- gstreamer installation problem: unmet dependencies

    falak.desai@yahoo.com

      Hello everyone,

      I'm using debian image on my intel edison mini breakout board. I want to install gstreamer on it.

      When I enter the following command, it shows the following output:

       

      Command:

      apt-get install gstreamer1.0

       

      Output:

       

      The following packages have unmet dependencies:

      gstreamer1.0-alsa : Depends: libgstreamer-plugins-base1.0-0 (>= 1.2.4) but it is not going to be installed

      gstreamer1.0-libav : Depends: libgstreamer-plugins-base1.0-0 (>= 1.0.0) but it is not going to be installed

      gstreamer1.0-plugins-bad : Depends: libgstreamer-plugins-bad1.0-0 (= 1.2.4-1~bpo70+1) but it is not going to be installed

                                  Depends: libgstreamer-plugins-base1.0-0 (>= 1.2.0) but it is not going to be installed

                                  Depends: liborc-0.4-0 (>= 1:0.4.18) but 1:0.4.16-2 is to be installed

      gstreamer1.0-plugins-base : Depends: liborc-0.4-0 (>= 1:0.4.18) but 1:0.4.16-2 is to be installed

                                   Depends: libgstreamer-plugins-base1.0-0 (>= 1.2.4) but it is not going to be installed

      gstreamer1.0-plugins-base-dbg : Depends: libgstreamer-plugins-base1.0-0 (= 1.2.4-1~bpo70+1) but it is not going to be installed

      gstreamer1.0-plugins-good : Depends: libgstreamer-plugins-base1.0-0 (>= 1.2.1) but it is not going to be installed

                                   Depends: liborc-0.4-0 (>= 1:0.4.18) but 1:0.4.16-2 is to be installed

      gstreamer1.0-plugins-ugly : Depends: libgstreamer-plugins-base1.0-0 (>= 1.0.0) but it is not going to be installed

                                   Depends: liborc-0.4-0 (>= 1:0.4.18) but 1:0.4.16-2 is to be installed

      gstreamer1.0-pulseaudio : Depends: libgstreamer-plugins-base1.0-0 (>= 1.0.0) but it is not going to be installed

      gstreamer1.0-x : Depends: libgstreamer-plugins-base1.0-0 (>= 1.2.4) but it is not going to be installed

      E: Unable to correct problems, you have held broken packages.

       

       

       

      I don't know what this error is, ans how to solve it.

      What should I do to resolve this. I've been working on this from last 3 days but didn't get any solution at all.

      please give me exact  steps & commands and links to resolve this issue. It's already taking too much longer now. 

       

      Thank you very much.