8 Replies Latest reply on Jul 24, 2015 7:48 PM by Itstechpro

    version 159  WEP  5 or 13 character problem

    Itstechpro

      Running version 159.  To fix the 5 or 13 character requirement, I downloaded configure_edison.py from GitHub with mods per Karsten's C code earlier posting.  Tried running but it errors out on the class  text_colors lines .... is there a simpler fix around ????  I saw an earlier post by Sergio stating that the version (?) he was running accepted between 8 and 63 characters ??????

      Thanks,

      JM

        • 1. Re: version 159  WEP  5 or 13 character problem
          Itstechpro

          I wasn't clear on the received errors in the posted question ...

          starting at line 15 ,, multiple 'command not found' errors for import, class, start, open

          line 119 ... syntax error near unexpected token

           

          execution stopped at that point

          • 2. Re: version 159  WEP  5 or 13 character problem
            Intel_Alvarado

            Hi,

            I’m also running version 159. I the run configure_edison –setup to do some tests. I’m first prompted to enter the password of the Edison, I entered a 3 character password to see what would be the result and I got a message saying “The device password must be between 8 and 63 characters long. Please try again.” Take a look at the picture.

            863.PNG

            I then continued with the setup process, I selected an SSID, connected to a network. To be able to connect to a network I need to enter the network password. This password must also be between 8 and 63 characters. Take a look at:

            8632.PNG

            Are you not seeing this behavior, please post screenshots of your terminal window. I downloaded my image from Intel® Edison Board Download | Intel® Developer Zone

             

            Sergio

            • 3. Re: version 159  WEP  5 or 13 character problem
              Itstechpro

              I'm going to reflash the version 159 already on the board so I can start from scratch and try the steps you indicated. When I tried previously, I got through the name and password sequence but did not see the same screen you indicated for the WiFi setup.  Will be back in a day or so.

              Thanks.

              • 4. Re: version 159  WEP  5 or 13 character problem
                Itstechpro

                Very strange.  Flash tool lite kept hanging during the stop the reboot phase after the board was plugged in.  Tried multiple times with no success and Windows reporting that the flash tool was non-responsive after several minutes..  Thinking that perhaps the password on the user I created during the first attempt at configuration was the problem, I deleted the password.  That seemed to fix the hang problem with the flash tool.  The flash failed at 76% but then completed successfully with no error messages on the next try.

                 

                The system looks OK from the serial port side.  Next step is to retry the configuration and network connection.

                • 5. Re: version 159  WEP  5 or 13 character problem
                  Itstechpro

                  No luck ... same problem, see attached screen shot ...  I did verify the version 159  .... cat /etc/version returns   'weekly-159'

                   

                  WiFi_fail.bmp

                  • 6. Re: version 159  WEP  5 or 13 character problem
                    xbolshe

                    Hi,

                     

                    WEP 40 bit ciphering requires 5 charaters as a password.

                    WEP 128 bit ciphering requires 13 charaters as a password.

                     

                    Need to change WEP to WPA, and 8..63 characters will be available.

                     

                    Need to switch hillfox#2 from WEP to WPA.

                     

                    BR,

                    xbolshe

                    • 7. Re: version 159  WEP  5 or 13 character problem
                      Itstechpro

                      Interesting but that doesn't help much. Have an older wireless access point / router that does not offer WAP security.  Apparently, previously posted information on changing the configure-edison code to accept variable WEP passwords doesn't seem to work for me.  Only possible avenue left short of buying a new wireless router is to change the password for that SSID to a 5 or 13 character one from the printable ASCII set of characters, eg,   "My34G" which in hex is 4D59333447.

                      • 8. Re: version 159  WEP  5 or 13 character problem
                        Itstechpro

                        Basic problem here is what we mean when we say 'characters'.

                        A 5 'character' WEP key (64 bits) is actually 5 hex pairs which normally requires 10 character to be entered from the keyboard, where each character can be 0-9 and A-F.  To enter the key as 5 printable and non printable ASCII characters from the keyboard, a mapping of the hex values of 00 through FF to keys or key combinations on your particular keyboard would be required.   Similarly, a 13 'character' WEP key (128 bits) is actually 13 hex pairs.  For example "My123Password", entered on the keyboard in response to the query from the Edison setup is equivalent to:

                        the hex string 4D7931323350617373776F7264  .... 26 key strokes.

                         

                        Granted that WPA security is the method of choice for most everyone these days, but I don't understand why the coding for WEP key entry in configure_edison restricts the possible character set for keys.

                         

                        I changed my router wep key to printable ASCII characters and successfully signed on.