2 Replies Latest reply on Jul 25, 2015 7:26 AM by Dalinian

    ICS with Ubuntu: Missing Suspend Function?

    Dalinian

      While I much appreciate the relatively low power requirements of the ICS's Atom CPU, to further minimise its carbon footprint in everyday use, I'd like to be able to sleep the system (as I'm familiar with doing on the elderly Intel Core Duo based Mac OS X system which I hope it will come to replace). In Ubuntu terminology, I'm looking to be able to 'Suspend' the system on the fly.

       

      However... where I'd expect to find a 'Suspend' menu item on the session menu (gear icon, right hand end of the menu bar), in between 'Log Out...' and 'Restart...', it is significant by its absence:

      Suspend is missing.jpg

      Missing 'Suspend' command - left: typical Ubuntu session menu - right my ICS with Ubuntu's session menu

       

      I've also tried using the Power control panel to set the system to 'Suspend when inactive for 5 minutes' - and although a pop-up warning says "Automatic suspend - the computer will suspend very soon because of inactivity" after c. 4 minutes of inactivity, the system still stays on and does not suspend.

       

      System sleeping does appear to be available on the ICS Windows version:

       

      "Putting the system to sleep averaged 2 seconds. Wake from sleep averaged 3 seconds."

      ~ Al Hill, in 'Intel Compute Stick - a user's first experience' [Windows version], 05 May 2015

      » https://communities.intel.com/docs/DOC-23998

       

      So, I'd like to ask:

       

      Q. Is there a way to get Ubuntu to 'Suspend' and make the ICS go to sleep?

       

      BTW & FWIW, although I'm an Ubuntu newbie, I'm fully aware as how there is a wealth of online community support for Ubuntu, where I'll also be seeking a solution to the ICS's missing 'Suspend' functionality; but if Intel's implementation of Ubuntu on the ICS has deliberately omitted 'Suspend' for some reason, then this forum would seem to be the right place to find out why that is.

        • 1. Re: ICS with Ubuntu: Missing Suspend Function?
          linuxium

          You can restore 'suspend' by removing the file '/etc/polkit-1/localauthority/50-local.d/com.ubuntu.disable-suspend.pkla'.  See How to disable suspend in 14.04? - Ask Ubuntu for further details.  However you might experience problems (rhetorical question: why the file was there in the first place?).

          • 2. Re: ICS with Ubuntu: Missing Suspend Function?
            Dalinian

            Many thanks for your accurate suggestion, linuxium - thanks to which I've succeeded in restoring 'Suspend' to the session menu; but... (to be continued).

             

            Turns out I didn't have permission to even look into '/etc/polkit-1/localauthority' - so I had to use 'sudo nautilus' in a terminal window to run the file manager as root, and that worked OK. Rather than just delete 'com.ubuntu.disable-suspend.pkla', I copied a backup to '~/Documents/Temp' for safe keeping, then quietened the original's efficacy by changing its name to 'com.ubuntu.disable-suspend.pkla.q' (ie: by adding '.q'). Sure enough, after a Logout / Login cycle, I could now see 'Suspend' to the session menu; however...

             

            Here's what occurs when I choose the newly restored 'Suspend’ command from the session menu:

            • screen goes blank,
            • couple of seconds pause,
            • screen comes back on again,
            • pop-up alert: "Disconnected - you are now offline [wifi network name]", and finally
            • pop-up alert: "Connected [wifi network name]".

            Same thing happens when it's set to 'Suspend when inactive for 5 minutes' in the Power control panel. In short, looks very much like Ubuntu 14.04 cannot suspend the ICS.

             

            Reading between the lines, it seems most likely that Intel just gave up on trying to get Ubuntu 14.04 to sleep the ICS in the way that Windows 8.1 obviously can - and so they used the 'com.ubuntu.disable-suspend.pkla' mechanism in '/etc/polkit-1/localauthority/50-local.d' to simply remove the 'Suspend' command from the session menu.

             

            Frankly, I've found Ubuntu 14.04 on the ICS (onna quad-core Intel Atom Z3735F processor, July 2014 vintage, 1.33 GHz to 2.16 GHz) to be so utterly lacklustre compared to OS X 10.9 on my old MacBook Pro (onna dual-core Intel Core 2 Duo processor, January 2008 vintage, 2.5 GHz) that the Ubuntu ICS has been relegated to being an emergencies only contingency device - one which adds resilience, but isn't in day to day use. While the Ubuntu ICS can just about do one thing at a time, it is soooo woefully under-resourced in RAM and storage that it is a frustratingly slow and inept computer to use. So it's looking very much like I'll need to spring for a more competent and expensive contemporary Ubuntu PC (eg: System76 Meerkat » https://system76.com/desktops/meerkat ) to get a system that exceeds a 2008 MacBook Pro.