4 Replies Latest reply on Oct 30, 2009 10:39 AM by JohnTimmel

    'This drive is not Intel SSD' firmware update issue

    yemski

      I have two X-25M G2 80gb.  I put one in a brand new system (Win7 x64) and the other I put in an existing system (also Win7 x64 on the SSD but dual booting with Vista x64 on a regular drive).  The SSD I put in my new system is detected fine by the firmware update tool, but the one I put in my existing system gives the following error "This drive is not Intel SSD" .  I made sure that in the bios I was in AHCI mode, I also tried enabling the legacy support in my SATA settings.  I also made sure the SSD was going through the southbridge SATA ports and not the additional Jmicron ports, but it still gives the same error message.   The drive is recognized as Intel SSD in the bios SATA settings and already has Win7 x64 installed on it, although I tried the older firmware update tool when I first got the SSD and got the same error message.

       

      If anyone has any input or advice it would be greatly appreciated.  I emailed intel support and did not receive a response (about a week ago) .  My mobo is the EVGA X58 SLI.  Thanks in advance.

        • 1. Re: 'This drive is not Intel SSD' firmware update issue
          philophob

          hey, i had the same error (also same mobo as well. and I have Win 7 x64 too)

          go into your bios and set the option to "IDE"(w/ legacy support enabled, at least that's what i did but I am not sure if that made any difference) instead of "AHCI" then restart and let the firmware CD runs itself.

          That is what I did to get it to work. The firmware setup should be able to see your SSD now.

          Good luck.

           

          [Edit] Right after you do firmware flash, go into Win 7. It will ask you to restart, do the restart. BEFORE it boots back into Win 7, GO INTO BIOS, and SET your option back to AHCI from IDE. (I read about this somewhere here or some other board online but I think this is crucial part, maybe not but I think you should do this as I read that the Intel Trim command works only under AHCI? not 100% sure but just to be on safe side,  you know.)

           

          p.s. I guess I am lucked out as my Win 7 rebooted fine and I ran few games and it works fine. Also ran the Intel SSD toolbox thingy to "trim" the SSD and my SSD got faster (it was @ 229 mb/s but now it's @ 240 mb/s) Hope you get thig sorted out.

          • 2. Re: 'This drive is not Intel SSD' firmware update issue
            yemski

            Thanks Philophob this worked.  I was able to update the firmware but unfortunetly I am now part of the firmware hosed my SSD club (thanks Intel!).  In any case I really appreciate your help, especially since intel support could not even be bothered to reply to my support emails.

            • 3. Re: 'This drive is not Intel SSD' firmware update issue
              JohnTimmel

              I have an X25-M "G2" 80G SSD. Running the toolbox on Windows XP Pro SP3 it says "Error Connecting to Drive" under the "drive selection".

              The non-SSD SATA hard drive is greyed out but has the same status of "Error Connecting to Drive".

              If I click on refresh, the 3 of the 5 function buttons display "Intel SSDs Only". The SATA controller is an NVIDIA nForce 430/410 Serial ATA My guess it's related to the SATA controller. I don't see any options in my BIOS for any sort of compatability IDE mode, etc.

              The SSD works flawlessly. I'll wait for things to settle before trying any updates.

              • 4. Re: 'This drive is not Intel SSD' firmware update issue
                JohnTimmel

                I removed the NVIDIA driver (deleted in device manager) and the toolbox works.

                See the following thread from the Intel folks.

                http://communities.intel.com/message/71325#71325   (shortcut on rt side of of the screen in this forum)