7 Replies Latest reply on Jul 27, 2015 4:40 AM by Nick_O.

    Pretty much everything has failed - What am I doing wrong?

    Nick_O.

      This is going to be a bit of a litany so I apologise for that.

       

      I received my board the other day and commenced the installation procedure as described in the Getting Started guide. The physical installation of the Edison onto the Arduino board seemed to work. Initially the board showed up as a USB device on Windows 7.

       

      1. When I plug a 12V 1A wall wart into the power socket, the light does came on as described in the Getting Started guide. Some time later, after one or more reboots I got no light and the three solder pins on the under side just get hot.

       

      2. When I plug in the power/data/Arduino micro usb (next to the switch) I get three lights in a pattern, DS1 (long) followed by DS2 (shorter) followed by DS3 (short flash). Is this correct? The Getting Started guided did not mention any other lights


      3. I tried the x64 installer and got Arduino IDE and Eclipse installed but at the very end of the process there was an error which indicated that I should follow the manual image installation procedure. I can't find the URL just now but it was the one that starts with downloading the image followed by removing old images etc. I got the the USB driver installation part and the message came up saying that the USB driver was already installed. I clicked Yes and it went ahead and removed the existing driver and attempted to install it again. This showed four failures both in removal and installation giving the following message in the log (over and over):

      x64 os

      Windows version: 7

      CertMgr.exe MFLD_USB_driver_cert.cer returned 0

      Installing drivers, please wait

      drvinstall.exe intc_usbcomp.inf returned 0

      drvinstall.exe intc_rndis.inf returned 0

      drvinstall.exe intc_cdcserial.inf returned 0

      drvinstall.exe intc_dfu.inf returned 0

       

      Despite the failures both the install and removal procedure reported success. The USB connection to the board was lost (i.e. it not longer showed up in Windows exploring and the x64 installation tool told me to connect the board even thought the USB cable was connected and the board was powered up). My Host controller needed reinstallation as well.

       

      There was another thread about this problem but it ended without specific recommendations. There was a suggestion that the firmware be reflashed to I attempted that.

       

      4. My first attempt was to use the manual process also described in the Getting Started guide. I installed the serial emulator for USB and connected to the second micro USB slot. Using putty I did not get the Yocto log in prompt and the board seemed to be in a permanent loop showing the following:

       

       

      ******************************

      PSH KERNEL VERSION: b0182727

                      WR: 20104000

      ******************************

       

       

      SCU IPC: 0x800000d0  0xfffce92c

       

       

      PSH miaHOB version: TNG.B0.VVBD.0000000c

       

       

      microkernel built 23:15:13 Apr 24 2014

       

       

      ******* PSH loader *******

      PCM page cache size = 192 KB

      Cache Constraint = 0 Pages

      Arming IPC driver ..

      Adding page store pool ..

      PagestoreAddr(IMR Start Address) = 0x04899000

      pageStoreSize(IMR Size)          = 0x00080000

       

       

      *** Ready to receive application ***

       

       

       

       

      U-Boot 2014.04 (Aug 20 2014 - 16:08:32)

       

       

             Watchdog enabled

      DRAM:  980.6 MiB

       

      The next attempt was to use the flash tool under Ubuntu 12.04. The board did not show up as a USB device in the file manager. The install was fine and when the board was physically connected it showed "Connected on port 8" for about 5 seconds then "Disconnected" for about 3 seconds. When I attempted to flash it got to between 23% and 30% before failing. I will attempt to attach the log because it is a bit large for a post.

       

      Connecting to the board under Ubuntu using "screen" gave the same result as with putty under Windows.

       

      So I'm a but stuck. I can't see the board via USB or via the serial interface and so I really have nowhere to go.

       

      Can someone give me some pointers please.

       

      nick