11 Replies Latest reply on Jul 14, 2015 9:24 AM by JernejH

    Galileo 1 Terminal access

    poseid

      Hi,

       

      I was following the steps from this sparkfun tutorial Galileo Getting Started Guide - learn.sparkfun.com

       

      Now, after uploading that sketch, and I run:

       

          screen /dev/cu.usbfd111 115200

       

      I'll see some strange byte sequence dump.

       

      Now, the Galileo seems to hang, also from the Arduino IDE - what can I do to troubleshoot this?

        • 1. Re: Galileo 1 Terminal access
          Intel_Alvarado

          Hi,

           

          What exactly are you trying to do, just enter the terminal? If this is the case then the easiest way would be to download a terminal emulator such as Putty PuTTY Download Page . From putty you can easily get terminal access through serial and ssh. You won’t need to run any sketches or do any additional commands just to login. In the Custom Arduino Sketch you can see a section that states “One warning here: this sketch does mess with some of the basic workings of the Galileo.” From putty you would just have to select the COM port and the baud speed to get you started.

           

          Sergio

          • 2. Re: Galileo 1 Terminal access
            poseid

            The goal was to login into the Linux system (similar to what I saw with the Edison board)

             

            Now, I can't access the board anymore.

             

            * Is there some kind of factory reset on the board?

            * What means of communication are there when the simple serial console does not show up?

             

            My setup is as simple as in:

             

            Screen Shot 2015-07-13 at 21.41.50.png

            • 3. Re: Galileo 1 Terminal access
              poseid

              A small remark: I tried to login with serial port without any uploading of sketches (also on the Galileo v. 2) but no terminal or simlar was received.

              • 4. Re: Galileo 1 Terminal access
                poseid

                The Arduino Yun has actually a nice tutorial how to access the board from a serial terminal: Networking with the Arduino Yun | Teach Me To Make

                • 5. Re: Galileo 1 Terminal access
                  PepeHoernchen

                  I'm also working with my Intel Galileo for some weeks now, or better: Trying to work with it. There are always some small setbacks that make it hard. Like this one just now: I was also trying a serial connection, and because I don't have the cable with the 3.5 mm jack, I wanted to do it with the "normal" USB by uploading a special Arduino sketch that switches the serial ports on the board (Galileo Getting Started Guide - learn.sparkfun.com). Then I connected via Putty, and I was able to log in - but when I tried some basic Linux commands, execution seemed to fail... I just got an empty line in the window and nothing happened ever more... Does anyone have a solution for that?

                  • 6. Re: Galileo 1 Terminal access
                    poseid

                    Thanks! Well, the serial cable with 3.5mm is special indeed. That is only the situation for the Galileo 1 if I understood correctly? So, I also tried to upload that sketch from SparkFun, but after that I only saw some strange bytesequence.

                    • 7. Re: Galileo 1 Terminal access
                      JernejH

                      Hi poseid,

                       

                      Galileo gen 1 has two micro USB ports. One for programing and uploading Arduino sketch the other is used to connect devices. Have you checked that you are using the right one?

                       

                      Also, the problem you could have, that for some reason Galileo is not booting from SD card, if you have a spare SD card create another image and try with that one. For some reason I had problems because image on SD card stopped working at one point (after first power down) and also Arduino environment was acting similar to your description. I figured this out when I got serial cable and could see what is going on. But I use gen 2.

                       

                      Cheers

                      • 8. Re: Galileo 1 Terminal access
                        poseid

                        Interesting idea if another SD card would boot, that might help. I'll check this at the next occasion.

                         

                        Just to be sure, there is no hidden reset sequence or other boot-mode that would allow a factory reset of the board?

                        • 9. Re: Galileo 1 Terminal access
                          PepeHoernchen

                          Ok I used a new SD card and a new image - not really a bootable though, I just unzipped the download image files into the SD card (as described in Galileo Getting Started Guide - learn.sparkfun.com). So now everything works better than before, but still not good:

                           

                          Trying the serial connection with the sketch and USB as described above again, I finally get some feedback from the board - meaning when I type the command "ls", it tells me that this command cannot be found. And I'm able to start Python, but then every execution of any command fails. Why??!

                           

                          I'm kinda impressed by this board's sneakyness...

                          • 10. Re: Galileo 1 Terminal access
                            poseid

                            Thanks, the SD Card looks very interesting. Looking back at the SparkFun post and to what it links to, I see:

                             

                            • The recommended Linux distribution is limited. Don’t go in expecting anything like a flavor of Debian (no apt-get makes for a sad Linux-newbie). I definitely recommend throwing an SD card in there with the “big” Linux image, which adds WiFi support as well as the fun stuff like Python, SSH, node.js, ALSA, V4L2, and openCV.
                            • A personal nitpick: to interact with the Linux terminal, one of the Galileo’s UARTs is converted, on-board, to RS-232 and sent out through a 3.5mm “stereo” jack. To connect that up to my computer, I need a weird combination of 3.5mm-to-DB9 RS-232 cable, and then a RS-232-to-USB cable to my computer. It works, but I’d rather it just output a simple TTL UART signal, which I can convert as I please.

                             

                            Meaning there is no SSH running by default - that is a pitty, as the Linux setup on the Edison is great, and I expected something similar on the Galileo. There is some more discussion about the boards "hidden" features here: Enginursday: Exploring the Arduino/Intel Galileo - News - SparkFun Electronics

                            • 11. Re: Galileo 1 Terminal access
                              JernejH

                              Hi poseid,

                               

                              If you run Galileo without SD image, it will load default image, which is saved in flash memory. This also hapens when SD card has currupt image or unbootable. Have you tried to update the firmware? If you made brick out of Galileo , there is a guide how to unmade it. But you will need "special" cable and programator. But as long as you can see Galileo it in COM devices it should be ok.

                               

                              Re: Bricked Galileo? Assert EFI ERROR

                               

                              @ PepeHoernchen Yes, these boards are sneaky

                               

                              Cheers, Jernej