2 Replies Latest reply on Jul 13, 2015 4:35 AM by leydar

    How to prevent Sketch loading on boot

    leydar

      Hi,

          I'm currently attached to and Edison board configured with an Arduino Sketch which is causing a perpetual reboot. I've stopped the boot at the U-Boot prompt but I can't figure out how to either delete /sketch/sketch.elf or stop it automatically loading. I've looked through the command list but I can't figure out how to really use anything that helps.

       

      Stephen

        • 1. Re: How to prevent Sketch loading on boot
          CMata_Intel

          Hi leydar,

           

          If you are able to get in the command prompt, you can run:

          root@edison:~# systemctl stop clloader.service
          root@edison:~# systemctl disable clloader.service
          root@edison:~# systemctl mask clloader.service
          

          Or you can delete the files:

          /sketch/sketch.elf

          /etc/systemd/system/multi-user.target.wants/clloader.service

          /lib/systemd/system/clloader.service

           

          Are you able to enter in the command prompt? Or it reboots automatically?  If you are not able to enter in the command prompt you should reflash the board.

           

          Regards,

          Charlie

          • 2. Re: How to prevent Sketch loading on boot
            leydar

            Hi Charlie,

                thanks for taking the time to reply. As I mentioned I could only get into the u-boot prompt, not the shell prompt. I flashed the board from there and started again.

             

            Stephen