3 Replies Latest reply on Jul 8, 2015 4:44 AM by Natalia_V.

    Haswell-ULT Integrated Graphics Controller vs 3rd Gen Core processor Graphics Controller

    Natalia_V.

      Good afternoon!

       

      I have Lenovo IdeaPad G500A (59-381065) notebook with Intel HD Graphics 4000 and AMD Radeon HD 8750M videocards inside. I use Linux openSUSE 13.1 (tried also other distributions with the same result).

       

      The problem is that graphics doesn't start on AMD card with fglrx driver:

      . . .
      <6>[fglrx] Try to set gart size 2697M failed, should be within 0M and 0M. Discard the setting.
      . . .
      

      in dmesg and

      . . .
      [    26.319] (EE) fglrx(0): Failed to open CMMQS connection.
      . . .
      

      in /var/log/Xorg.0.conf.

       

      In the same time it does run on the very similar notebook Acer Aspire E1-572G (this is described in AMD / Intel drivers problem) without any problems. Olav from that discussion and I have the same AMD cards. Our Intel cards are different:

      Olav's

      # lspci -nnk | grep 'VGA'

      00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09)

      vs my

      # lspci -nnk | grep 'VGA'

      00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)

       

      This is the most obvious difference of our machines in relation to my problem (I don't think that the manufacturer of notebook as whole does matter...).

       

      Could anybody explain what is the difference between these two integrated cards in the relation to the problem?

       

      If anybody has the similar notebook (with working Intel/AMD PowerXpress with fglrx), please, provide the result of

      # lspci -vvvxxxnn -s 00:00:02.0 && lspci -vvvxxxnn -s 00:01:00.0

      where 00:00:02.0 and 00:01:00.0 are the BusIDs of the videocards (taken from the result of lspci command).

       

      Any help is appreciated.

      Regards, Natalia