2 Replies Latest reply on Jul 6, 2015 8:22 AM by Intel_Alvarado

    installing latest update

    philtkp

      HI,

      Need some help getting my Arduino Edison working correctly and I'm a novice, I was unable to see the Edison drive. I tried "reboot_ota", and "run do_ota" . I reformatted the drive as it was showing as unallocated using fat32. that now shows the drive. But, when the board reboots it fails to mount. but this is all I get. any help would be great

       

       

       

      ******************************
      PSH KERNEL VERSION: b0182b2b
                      WR: 20104000
      ******************************

      SCU IPC: 0x800000d0  0xfffce92c

      PSH miaHOB version: TNG.B0.VVBD.0000000c

      microkernel built 11:24:08 Feb  5 2015

      ******* PSH loader *******
      PCM page cache size = 192 KB
      Cache Constraint = 0 Pages
      Arming IPC driver ..
      Adding page store pool ..
      PagestoreAddr(IMR Start Address) = 0x04899000
      pageStoreSize(IMR Size)          = 0x00080000

      *** Ready to receive application ***


      U-Boot 2014.04 (Jun 19 2015 - 12:05:55)

             Watchdog enabled
      DRAM:  980.6 MiB
      MMC:   tangier_sdhci: 0
      In:    serial
      Out:   serial
      Err:   serial
      Hit any key to stop autoboot:  0
      Target:blank
      Partitioning already done...
      Flashing already done...
      GADGET DRIVER: usb_dnl_dfu
      reading vmlinuz
      5434848 bytes read in 134 ms (38.7 MiB/s)
      Valid Boot Flag
      Setup Size = 0x00003c00
      Magic signature found
      Using boot protocol version 2.0c
      Linux kernel version 3.10.17-poky-edison+ (sys_dswci@tlsndgbuild004) #1 SMP PREEMPT Fri Jun 19 12:06:40 CEST 2015
      Building boot_params at 0x00090000
      Loading bzImage at address 00100000 (5419488 bytes)
      Magic signature found
      Kernel command line: "rootwait root=PARTUUID=012b3303-34ac-284d-99b4-34e03a2335f4 rootfstype=ext4 console=ttyMFD2 earlyprintk=ttyMFD2,keep loglevel=4 g_multi.ethernet_config=rndis systemd.unit=multi-user.target hardware_id=00 g_multi.iSerialNumber=790a795aec7f60bed06dbaf8992a8a5a g_multi.dev_addr=02:00:86:2a:8a:5a platform_mrfld_audio.audio_codec=dummy"

      Starting kernel ...

      [    1.602566] snd_soc_sst_platform: Enter:sst_soc_probe
      [    2.006323] pmic_ccsm pmic_ccsm: Error reading battery profile from battid frmwrk
      [    2.024492] pmic_ccsm pmic_ccsm: Battery Over heat exception

      Welcome to Linux!

               Expecting device dev-ttyMFD2.device...
      [  OK  ] Reached target Remote File Systems.
               Expecting device dev-disk-by\x2dpartlabel-factory.device...
               Expecting device sys-subsystem-net-devices-usb0.device...
      [  OK  ] Reached target Paths.
      [  OK  ] Reached target Swap.
      [  OK  ] Set up automount boot.automount.
      [  OK  ] Created slice Root Slice.
      [  OK  ] Created slice User and Session Slice.
      [  OK  ] Listening on Delayed Shutdown Socket.
      [  OK  ] Listening on /dev/initctl Compatibility Named Pipe.
      [  OK  ] Listening on udev Control Socket.
      [  OK  ] Listening on udev Kernel Socket.
      [  OK  ] Listening on Journal Socket.
      [  OK  ] Created slice System Slice.
               Mounting Temporary Directory...
      [  OK  ] Created slice system-serial\x2dgetty.slice.
      [  OK  ] Created slice system-getty.slice.
               Starting Load Kernel Modules...
               Starting Create list of required static device nodes...rrent kernel...
               Starting udev Coldplug all Devices...
               Mounting Debug File System...
               Mounting POSIX Message Queue File System...
               Starting Apply Kernel Variables...
               Starting Journal Service...
      [  OK  ] Started Journal Service.
      [  OK  ] Reached target Slices.
               Starting Remount Root and Kernel File Systems...
      [  OK  ] Set up automount home.automount.
      [  OK  ] Mounted POSIX Message Queue File System.
      [  OK  ] Mounted Debug File System.
      [  OK  ] Mounted Temporary Directory.
      [  OK  ] Started Create list of required static device nodes ...current kernel.
      [  OK  ] Started Apply Kernel Variables.
      [  OK  ] Started Remount Root and Kernel File Systems.
      [  OK  ] Started Load Kernel Modules.
      [  OK  ] Started udev Coldplug all Devices.
               Mounting Configuration File System...
               Mounting FUSE Control File System...
               Starting Load/Save Random Seed...
               Starting Create Static Device Nodes in /dev...
      [  OK  ] Mounted FUSE Control File System.
      [  OK  ] Mounted Configuration File System.
      [  OK  ] Started Load/Save Random Seed.
      [  OK  ] Started Create Static Device Nodes in /dev.
               Starting udev Kernel Device Manager...
      [  OK  ] Reached target Local File Systems (Pre).
               Mounting /var/volatile...
      [  OK  ] Started udev Kernel Device Manager.
      [  OK  ] Mounted /var/volatile.
      [  OK  ] Reached target Local File Systems.
               Starting Trigger Flushing of Journal to Persistent Storage...
               Starting Create Volatile Files and Directories...
      [  OK  ] Started Create Volatile Files and Directories.
      [  OK  ] Started Trigger Flushing of Journal to Persistent Storage.
      [  OK  ] Created slice system-systemd\x2drfkill.slice.
               Starting Load/Save RF Kill Switch Status of rfkill0...
               Starting Load/Save RF Kill Switch Status of rfkill2...
               Starting Load/Save RF Kill Switch Status of rfkill1...
               Starting Network Time Synchronization...
               Starting Update UTMP about System Boot/Shutdown...
      [  OK  ] Found device /sys/subsystem/net/devices/usb0.
      [  OK  ] Found device /dev/disk/by-partlabel/factory.
      [  OK  ] Started Load/Save RF Kill Switch Status of rfkill2.
      [  OK  ] Started Load/Save RF Kill Switch Status of rfkill0.
      [  OK  ] Started Load/Save RF Kill Switch Status of rfkill1.
      [  OK  ] Found device /dev/ttyMFD2.
      [  OK  ] Started Update UTMP about System Boot/Shutdown.
      [  OK  ] Started Network Time Synchronization.
      [  OK  ] Reached target Sound Card.
      [  OK  ] Reached target System Initialization.
      [  OK  ] Listening on RPCbind Server Activation Socket.
      [  OK  ] Listening on D-Bus System Message Bus Socket.
      [  OK  ] Reached target Timers.
               Starting Restore Sound Card State...
               Mounting Mount for factory...
      [  OK  ] Listening on sshd.socket.
      [  OK  ] Mounted Mount for factory.
      [  OK  ] Reached target Sockets.
      [  OK  ] Reached target Basic System.
               Starting Edison PWR button handler...
      [  OK  ] Started Edison PWR button handler.
               Starting Telephony service...
               Starting Daemon to load edison mcu app binary...
      [  OK  ] Started Daemon to load edison mcu app binary.
      Application available at (physical) address 0x04819000
              VRL mapped to 0xff217000
              App size = 11508 bytes

              App Authentication feature is disabled!
              Resetting IPC

      *** Ready to receive application ***
               Starting Daemon to handle arduino sketches...
      [  OK  ] Started Daemon to handle arduino sketches.
               Starting Daemon to reset sketches...
      [  OK  ] Started Daemon to reset sketches.
               Starting Bluetooth rf kill event daemon...
      [  OK  ] Started Bluetooth rf kill event daemon.
               Starting Start or stop WiFI AP Mode in Edison...
      [  OK  ] Started Start or stop WiFI AP Mode in Edison.
               Starting Login Service...
               Starting D-Bus System Message Bus...
      [  OK  ] Started D-Bus System Message Bus.
      [  OK  ] Started Telephony service.
               Starting Network Service...
               Starting Watchdog sample daemon...
      [  OK  ] Started Watchdog sample daemon.
               Starting Crashlog service...
      [  OK  ] Started Crashlog service.
               Starting Cleanjournal service...
      [  OK  ] Started Cleanjournal service.
               Starting Permit User Sessions...
      [  OK  ] Started Network Service.
      [  OK  ] Started Permit User Sessions.
      [  OK  ] Started Login Service.
               Starting Bluetooth service...
      [  OK  ] Created slice system-systemd\x2dfsck.slice.
               Starting File System Check on /dev/disk/by-partlabel/boot...
               Starting File System Check on /dev/disk/by-partlabel/home...
               Starting Serial Getty on ttyMFD2...
      [  OK  ] Started Serial Getty on ttyMFD2.
               Starting Getty on tty1...
      [  OK  ] Started Getty on tty1.
      [  OK  ] Reached target Login Prompts.
      [  OK  ] Reached target Network.
               Starting Zero-configuration networking...
               Starting Mosquitto - lightweight server implementati...SN protocols...
               Starting Network Name Resolution...
      [    9.204882] systemd-fsck[224]: dosfsck 2.11, 12 Mar 2005, FAT32, LFN
      [    9.207606] systemd-fsck[224]: /dev/mmcblk0p7: 5 files, 2742/2971 clusters
      [  OK  ] Started File System Check on /dev/disk/by-partlabel/boot.
      [    9.245141] systemd-fsck[226]: fsck.ext2: Bad magic number in super-block while trying to open /dev/mmcblk0p10
      [    9.249103] systemd-fsck[226]: /dev/mmcblk0p10:
      [[    9.259478] systemd-fsck[226]: The superblock could not be read or does not describe a correct ext2
      [    9.275741] systemd-fsck[226]: filesystem.  If the device is valid and it really contains an ext2
      [    9.278004] systemd-fsck[226]: filesystem (and not swap or ufs or something else), then the superblock
        OK  ] Started Mosquitto - lightweight server implementatio...T-SN protocols.
      [    9.281165] systemd-fsck[226]: is corrupt, and you might try running e2fsck with an alternate superblock:
      [  OK  ] Started File System Check on /dev/disk/by-partlabel/home.
      [  OK  ] Started Zero-configuration networking.
      [    9.392067] systemd-fsck[226]: e2fsck -b 8193 <device>
      [  OK  ] Started Network Name Resolution.
      [  OK  ] Started Bluetooth service.
               Starting Hostname Service...
               Starting The Edison status and configuration service...
      [  OK  ] Started The Edison status and configuration service.
               Starting Intel_XDK_Daemon...
      [  OK  ] Started Intel_XDK_Daemon.
               Mounting /home...
               Mounting /boot...
      [  OK  ] Started Hostname Service.
      [  OK  ] Mounted /boot.
      [FAILED] Failed to mount /home.
      See 'systemctl status home.mount' for details.
               Mounting /home...
      [FAILED] Failed to mount /home.
      See 'systemctl status home.mount' for details.
      [  OK  ] Started Restore Sound Card State.
               Starting PulseAudio Sound System...
               Mounting /home...
      [FAILED] Failed to mount /home.
      See 'systemctl status home.mount' for details.
               Mounting /home...
      [FAILED] Failed to mount /home.
      See 'systemctl status home.mount' for details.
      [FAILED] Failed to start PulseAudio Sound System.
      See 'systemctl status pulseaudio.service' for details.
      [  OK  ] Reached target Multi-User System.

      Poky (Yocto Project Reference Distro) 1.7.2 edison ttyMFD2

      edison login:

        • 1. Re: installing latest update
          philtkp

          Finally resolved this. using an external power supply and both USB cables connected I was finally able to see the drive on my PC. I reformatted the drive using FAT32. has to do all manually because for some reason using the current Windows 64-bit Installer kept failing to install the updated image. I tried using the phone flash tool and it hung at 24%. after several attempts and reformats I was able to boot the Edison

          -copied a clean downloaded copy of the current image.

          -rebooted the card and stopped the auto boot process and used "run do-ota" after a while the board seemed to boot normal but wasn't recognized using the Arduino IDE.

          -rebooted the board and ran "reboot ota" from the terminal screen..... it did its thing and now all seems well.

          Running Arduino 1.6.5 r2 and a few projects I was working with. Oh and I don't need to use the external power supply.

           

          Question: could this been caused by not enough power from the USB port for the update?

          • 2. Re: installing latest update
            Intel_Alvarado

            Hi,

             

            Yes, certain USB slots on your system might not be able to provide enough power to the board. This can cause unpredictable behavior, especially when doing some tasks such as using Wi-Fi or doing some upgrades. When doing these tasks that require more power, an external power supply is the preferred way of powering the Edison.

             

            Sergio